[Bug 645745] [NEW] Some package dependency should be moved to puppet

kc7zzv 645745 at bugs.launchpad.net
Thu Sep 23 05:27:02 BST 2010


Public bug reported:

Binary package hint: puppet-common

Expected:
libshadow-ruby1.8 should not be required by puppet-common because the puppetmaster doesn't need to modify shadow passwords.  

Fix:
Instead the libshadow-ruby1.8 dependency should only be required by the puppet package (which is the client).

Affected version:
The affects puppet-common-2.6.1-0ubuntu1 and possibly other versions.

Note:
My understanding is that the adduser package should not be removed from the dependencys list because puppet uses it to add the "puppet" user if the user is missing.

** Affects: puppet (Ubuntu)
     Importance: Undecided
         Status: New

-- 
Some package dependency should be moved to puppet
https://bugs.launchpad.net/bugs/645745
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to puppet in ubuntu.



More information about the Ubuntu-server-bugs mailing list