[Bug 590929] Re: [SRU] eucalyptus create and delete volumes sometimes fail on lvm commands (POC + ENT configs)

Dustin Kirkland dustin.kirkland at gmail.com
Fri Sep 3 00:19:35 BST 2010


** Description changed:

  When testing out bug 586134 I found another issue and although similar
  to bug 517086 appears not to be the same issue.
  
  If you create for example 200 1GB volumes like this:
  
  for i in `seq 1 200` ; do euca-create-volume -z cluster1 -s 1 ; done
  
  You will end up with quite a few failed. If you look in the logs it is
  usually caused by vgcreate failing for unknown reasons as the output of
  the command is not logged. If you run the same command on the command
  line that failed it will then work.
  
  Also if you then delete all the volumes like this:
  
  for i in `euca-describe-volumes | awk '{print $2}'` ; do euca-delete-
  volume $i ; done
  
  You will end up with a huge number that do not get removed. If you look
  in the logs it is usually caused by lvremove failing for unknown reasons
  like with vgcreate. Again if you run the same command on the command
  line that failed it will then work.
  
  Also despite the failure to properly delete the volume euca-describe-
  volumes will have invalid information. For example if you delete the
  volume it will no longer show up in the list but it will still be there
  as seen by losetup and vgscan, and will still be set back up by
  eucalyptus when rebooted but it will not show up in the euca-describe-
  volume list.
  
  Chris
+ 
+ ===============
+ SRU INFORMATION
+ 
+ IMPACT:
+ This bug affects users of UEC, trying to create EBS volumes using the euca-create-volume command.  In the current packages, this command will fail from time to time, for no apparent or reported reason, and Eucalyptus does not recover gracefully and retry the volume creation.  This is a problem that heavy UEC users will probably encounter at some point in time.
+ 
+ HOW ADDRESSED:
+ This bug has been addressed by the upstream Eucalyptus maintainer of this code.  The Eucalyptus 2.0 branch (in Maverick) does not suffer from this bug, as much of the storage related code has been refactored in the interest of scalability.  Neil Soman has graciously backported the minimal subset of those changes necessary to address this bug.  Still the patch is a few hundred lines.   But it's all in the interest of solving this bug.
+ 
+ PATCH:
+ See bzr revisions r1235 and r1236 of lp:eucalyptus (upstream Eucalyptus branch).
+ 
+ REPRODUCE:
+ To reproduce this bug, simply:
+   for i in $(seq 1 40); do euca-create-volume -z cluster1 -s 1; done
+   sleep 10
+   euca-describe-volumes | grep fail
+   euca-describe-volumes | awk '{print $2}' | xargs -i euca-delete-volume {}
+ I see failures trying to create a few as 40 volumes.  (Note that I chose 40, as I have 50GB of disk free).  We would expect being able to do the above ad nauseum, without unhandled errors.
+ 
+ REGRESSION POTENTIAL:
+ There is perhaps some chance of regression in the storage related functionality in Eucalyptus.  For this reason, this particular SRU package will be heavily tested by Canonical OEM Server QA as well as Ubuntu Platform QA and Ubuntu Platform Server team members.
+ 
+ ===============

** Changed in: eucalyptus (Ubuntu Lucid)
    Milestone: None => ubuntu-10.04.2

-- 
[SRU] eucalyptus create and delete volumes sometimes fail on lvm commands (POC + ENT configs)
https://bugs.launchpad.net/bugs/590929
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to eucalyptus in ubuntu.



More information about the Ubuntu-server-bugs mailing list