[Bug 669443] [NEW] Terminal hangs when sshing to Ubuntu 10.04

Denis Shvydkiy 669443 at bugs.launchpad.net
Mon Nov 1 13:16:47 GMT 2010

Public bug reported:

When I ssh to a box with Ubuntu 10.04 Desktop edition terminal hangs
after issuing some commands like ls, vi etc.

In my case I tried to reproduce the issue with the following computers:
A. My laptop with Ubuntu 10.10 Desktop edition.
B. A box with Ubuntu 10.04 Desktop edition.
C. A VPS with Ubuntu 10.04 Server edition
D. A VPS with Ubuntu 8.04 Server edition.

When I try to ssh from A to C and D everything works fine, I can run vi,
ls, byobu etc.

When I ssh to from A to B I can login successfully and even ls works on
some directories but something like vi, nano hangs the terminal.

I tried to use gnome-terminal and putty and the issue is reproducible
with both.

There is a similar report at

** Affects: openssh (Ubuntu)
     Importance: Undecided
         Status: New

Terminal hangs when sshing to Ubuntu 10.04 
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to openssh in ubuntu.

More information about the Ubuntu-server-bugs mailing list