[Bug 538178] [NEW] MySQL crashes after I run sudo apt-get upgrade

Launchpad Bug Tracker 538178 at bugs.launchpad.net
Fri Mar 12 18:53:09 GMT 2010

You have been subscribed to a public bug:

Hi All,

I'm using a 64-bit version of Ubuntu 9.10 server on an Amazon EC2
instance.  Since a couple weeks ago, "sudo apt-get upgrade" has failed
because it can't upgrade MySQL successfully.  When I run apt-get
upgrade, the server downloads the latest MySQL files and stops the MySQL
daemon in order to upgrade the server.  But then it fails when trying to
start MySQL.

When I investigated the cause of this error, I realized that the cause
of the problem is that the "sudo apt-get upgrade" creates 2 binary log
files which have the root:root account and group as the owner.  These
binary log files are in the directory /var/lib/mysql/ and have names
like mysql-bin.000107.  I'm not sure why "sudo apt-get upgrade" creates
2 files, but it always seems to create 2 files.  When I change the owner
of these binary log files to mysql:mysql, then MySQL successfully

As a result of this bug, I haven't been able to successfully run sudo
apt-get upgrade for a couple weeks.  Any help or advice would be

Here is info about my server.

Output from lsb_release -rd
Description: Ubuntu 9.10
Release:	9.10

Amazon EC2 AMI: I created my own AMI but built it on top of the official
Canonical Ubuntu 64-bit 9.10 AMI in December, 2009.

** Affects: mysql-dfsg-5.1 (Ubuntu)
     Importance: Undecided
         Status: New

MySQL crashes after I run sudo apt-get upgrade
You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to mysql-dfsg-5.1 in ubuntu.

More information about the Ubuntu-server-bugs mailing list