[Bug 530877] [NEW] E:Unable to correct problems, you have held broken packages.

Launchpad Bug Tracker 530877 at bugs.launchpad.net
Tue Mar 2 19:25:57 GMT 2010


You have been subscribed to a public bug:

Binary package hint: update-manager

$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Failed
The following packages have unmet dependencies:
  phpmyadmin: Depends: php5-mcrypt but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  libapache2-mod-php5 linux-generic linux-headers-generic linux-image-generic
  php5-common php5-curl php5-gd php5-mysql
The following packages will be upgraded:
  capplets-data evolution-data-server evolution-data-server-common
  gnome-control-center gnome-user-share indicator-session kdebase-runtime-data
  kdelibs-bin kdelibs5 kdelibs5-data libcamel1.2-14 libebackend1.2-0
  libebook1.2-9 libecal1.2-7 libedata-book1.2-2 libedata-cal1.2-6
  libedataserver1.2-11 libedataserverui1.2-8 libegroupwise1.2-13
  libexchange-storage1.2-3 libgdata-google1.2-1 libgdata1.2-1 libgl1-mesa-dri
  libgl1-mesa-glx libglu1-mesa libgnome-window-settings1 libindicate-gtk2
  libindicate4 libmetacity-private0 libplasma3 libpolkit-gtk-1-0
  libwnck-common libwnck22 man-db mesa-utils metacity oxygen-icon-theme
  policykit-1-gnome rhythmbox rhythmbox-plugin-cdrecorder rhythmbox-plugins
  x11-common xbase-clients xorg xserver-common xserver-xorg xserver-xorg-core
  xserver-xorg-input-all xutils
49 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.
Need to get 44.7MB of archives.
After this operation, 106kB of additional disk space will be used.
Do you want to continue [Y/n]?

ProblemType: Bug
Architecture: amd64
Date: Tue Mar  2 19:34:15 2010
DistroRelease: Ubuntu 10.04
NonfreeKernelModules: nvidia
Package: update-manager 1:0.132.1
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=it_IT.UTF-8
 PATH=(custom, user)
 LANG=C
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
SourcePackage: update-manager
Uname: Linux 2.6.32-14-generic x86_64

** Affects: php5 (Ubuntu)
     Importance: Undecided
         Status: New


** Tags: amd64 apport-bug lucid
-- 
E:Unable to correct problems, you have held broken packages.
https://bugs.launchpad.net/bugs/530877
You received this bug notification because you are a member of Ubuntu Server Team, which is subscribed to php5 in ubuntu.



More information about the Ubuntu-server-bugs mailing list