[Bug 513562] [NEW] Windows 7 Pro machines trust relationship fails

Roger Abrahamsson roger at gnyrf.net
Thu Jan 28 02:50:57 GMT 2010


Public bug reported:

Binary package hint: samba

Windows 7 Pro clients, 32 bit. Joined to Samba domain, account handling in openldap. Worked fine for just about one month, then all machines installed on the same day simultaneously failed to login, error message was "the trust relationship between this workstation and the primary domain failed". A check in syslog revealed following from ldap server.
Jan 28 08:54:03 server1 slapd[1497]: conn=2365 op=2 do_search: invalid dn (sambaDomainName=,sambaDomainName=DOMAIN,dc=domain,dc=local)

sambaDomainName=DOMAIN,dc=domain,dc=local exists, but sambaDomainName=,sambaDomainName=DOMAIn,dc=domain,dc=local does not and cannot do either in LDAP if I understand things correctly.
Temporary solution is to drop machines from domain and rejoin, and they work, but not ideal at all.

ProblemType: Bug
Architecture: amd64
Date: Thu Jan 28 10:06:28 2010
DistroRelease: Ubuntu 9.10
Package: samba 2:3.4.0-3ubuntu5.3
ProcEnviron:
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-16.53-server
SourcePackage: samba
Uname: Linux 2.6.31-16-server x86_64

** Affects: samba (Ubuntu)
     Importance: Undecided
         Status: New


** Tags: amd64 apport-bug

-- 
Windows 7 Pro machines trust relationship fails
https://bugs.launchpad.net/bugs/513562
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to samba in ubuntu.



More information about the Ubuntu-server-bugs mailing list