[Bug 112631] Re: [apport] package slapd failed to install/upgrade:

murray ubuntu at focus-computing.com.au
Sat Feb 20 07:09:15 GMT 2010


Can I join this problem?

I've upgraded from Edgy to Karmic - this is a development machine so I'm
not too worried failure, however everything seemed to work okay which
was pretty amazing as I came through a number of EOL supported releases.

Anyways, the point of doing this upgrade was to test my my application
with OpenLDAP, however my LDAP system won't now run.

PS I did have the LDAP server working on Edgy before this started...

Through the upgrade I was getting errors about SLAPD regarding
<schemacheck> and <checkpoint> not being valid directives... so I
commented them out. And tried to continue.  Then I was getting errors
about the database can't be opened so I tried to remove the package and
then --reinstall and now I'm getting a version error:

root at rimu:~# sudo apt-get install slapd ldap-utils
Reading package lists... Done
Building dependency tree
Reading state information... Done
slapd is already the newest version.
ldap-utils is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up slapd (2.4.18-0ubuntu1) ...
  Backing up /etc/ldap/slapd.conf in /var/backups/slapd-2.2.26-5ubuntu3.3... done.
failed.

Migrating slapd.conf file (/etc/ldap/slapd.conf) to slapd.d failed with the following error while running slaptest:
    bdb(dc=myfocus,dc=com): Program version 4.7 doesn't match environment version 0.33
    bdb_db_open: database "dc=myfocus,dc=com" cannot be opened, err -30971. Restore from backup!
    backend_startup_one (type=bdb, suffix="dc=myfocus,dc=com"): bi_db_open failed! (-30971)
    slap_startup failed (test would succeed using the -u switch)
dpkg: error processing slapd (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 slapd
E: Sub-process /usr/bin/dpkg returned an error code (1)

I just want to get OpenLDAP working again.  How can I now get to a fresh
install of this package???  Any attempt to remove or install now results
in this same error!

HHHEEELLLPPP  I'm absolutely stuck with no where to go.... well, maybe
with the exception of some other Linux version...

PS I'll upload my slapd.conf as well.  Let me know if you need anything
else.

Cheers
Murray

-- 
[apport] package slapd failed to install/upgrade: 
https://bugs.launchpad.net/bugs/112631
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to openldap in ubuntu.



More information about the Ubuntu-server-bugs mailing list