[Bug 486128] [NEW] euca2ools: Requires more environment variables than EC2 AMI tools

Eric Hammond ehammond at thinksome.com
Sat Nov 21 01:44:09 GMT 2009

Public bug reported:

Binary package hint: euca2ools

As I understand it,  one of the goals in Ubuntu is for euca2ools to be a
drop in replacement for Amazon's EC2 AMI (and API) command line tools.

The following are differences where I noticed that I had to set
additional environment variables for euca2ools to function properly.

- euca-upload-bundle requires setting S3_URL instead of just defaulting
to https://s3.amazonaws.com as ec2-upload-bundle does.

- euca-register requires setting $EC2_URL instead of defaulting to
https://ec2.amazonaws.com as ec2-register does.

- euca-register requires setting $EC2_ACCESS_KEY and $EC2_SECRET_KEY
instead of also checking $AWS_ACCESS_KEY_ID and
$AWS_SECRET_ACCESS_KEY_ID as ec2-register does.

See also: bug 435140

ProblemType: Bug
Architecture: i386
Date: Sat Nov 21 01:38:11 2009
DistroRelease: Ubuntu 9.10
Ec2AMI: ami-1515f67c
Ec2AMIManifest: ubuntu-images-us/ubuntu-karmic-9.10-i386-server-20091027.1.manifest.xml
Ec2AvailabilityZone: us-east-1a
Ec2InstanceType: m1.small
Ec2Kernel: aki-5f15f636
Ec2Ramdisk: ari-0915f660
Package: euca2ools 1.0+bzr20091007-0ubuntu1
PackageArchitecture: all
ProcVersionSignature: User Name 2.6.31-302.7-ec2
SourcePackage: euca2ools
Tags: ec2-images
Uname: Linux 2.6.31-302-ec2 i686

** Affects: euca2ools (Ubuntu)
     Importance: Undecided
         Status: New

** Tags: apport-bug ec2-images i386 uec-images

euca2ools: Requires more environment variables than EC2 AMI tools
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to euca2ools in ubuntu.

More information about the Ubuntu-server-bugs mailing list