[Bug 482836] [NEW] Samba shared printers not accessible under Vista and Windows7

Herr Irrtum die-nmi at gmx.de
Sat Nov 14 22:30:35 GMT 2009

Public bug reported:

Binary package hint: samba

1. Ubuntu release:

#uname -a
Linux maedchentank 2.6.31-15-generic #49-Ubuntu SMP Fri Nov 6 09:55:13 UTC 2009 x86_64 GNU/Linux
# lsb_release -rd
Description:    Ubuntu 9.10
Release:        9.10

2. involved packages:

~# apt-cache policy cups
  Installiert: 1.4.1-5ubuntu2.1
  Kandidat: 1.4.1-5ubuntu2.1
~# apt-cache policy samba
  Installiert: 2:3.4.0-3ubuntu5.1
  Kandidat: 2:3.4.0-3ubuntu5.1

3. What should happen:
Connecting to shared printers on my ubuntu 9.10 server from within windows vista64 and windows7 brings up the windows printer dialog - as is happened in ubuntu 9.04.

4, What happens instead

Connecting to shared printers on my ubuntu 9.10 server from within windows vista(64 Bit) and windows7 (64 Bit)  brings a "Druckerverbindung kann nicht hergestellt werden - 0x0000000d" on Windows (exact english translation not known - should be something like "unable to connect to printer - 0x0000000d". Windows isn't telling more. The Windows Support Entry in the web about this error number is compete nonsense.
However Windows XP (32 Bit) clients connect without a problem.
Note that exactly the same Vista (64 Bit) machine (even without any LSA-Manipulations within the registry (as it is still recommanded here and there)) did work with the same smb.conf on the same server with ubuntu 9.04 (it was updated to 9.10 - meaning it was not a fresh install).
Typical folder shares on the server are no problem for vista and windows7.

BTW: Trying to get a clean new smb file is not easy because of this
dpkg-reconfigure samba crash

# dpkg-reconfigure samba
 * Stopping Samba daemons                                                                                                    [ OK ]
   [doing stuff within the nc gui until the "create /var/lib/samba/passdb.tdb?" Question and then...]
sed: -e Ausdruck #1, Zeichen 143: Unbekannte Option für `s'

However I am sure to have a clean smb.conf. The most interesting section
is this (and I already tried to "open" it up as much as it may be

load printers = yes

   printing = cups
   printcap name = cups


   comment = All Printers
   browseable = no
   path = /var/spool/samba
   printable = yes
   guest ok = yes
   read only = yes
   create mask = 0700
#  inserted ny me
   use client driver = yes

# Windows clients look for this share name as a source of downloadable
# printer drivers

# disabling or not disabling - the [print$] Section is of course not
changig anything here

# ----------------------------------
# [print$]
#   comment = Printer Drivers
#   path = /var/lib/samba/printers
#   browseable = yes
#   read only = yes
# #   guest ok = no
# # changed by me
#     guest ok = yes
# ---------------------------------


Security levels is users. Password backend is tdbsam. 
Users trying to connect to the printers (2 printers - one usb and cups-pdf) are already connected to shared folders on the server successfully (so it is not a credentials problem from this side). They are also known to samba thanks to smbpasswd.

On the cups side both printers are set to shared. So anything should
just work like it does perfectly with Windows XP Clients (32Bit) within
the same network or like unter Ubuntu 9.04 with the same configuration
(also with vista64 Clients there).

I've tried alot about this with no success. 
I was surprised not to find a bug report about this, because, if you google about "karmic printer vista" you find a lot forum questions about this - and they all try a lot even unrelated things to get rid of this - but the issue remains unsolved. 
Like here: <http://ubuntuforums.org/showthread.php?p=8263192>

Sidenote: Also strange: After starting/restarting the whole server, all
samba folder shares work perfectly - but not even one printer is showing
up (at least not on the vista/win7 clients here).  Doing a
"/etc/init.d/samba restart" on the server makes them visible. This can't
be a sort of "late usb printer detection" issue, as cups-pdf shouldn't
be affected by such things. I did not investigate much into this

Herr Irrtum.

** Affects: samba (Ubuntu)
     Importance: Undecided
         Status: New

Samba shared printers not accessible under Vista and Windows7
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to samba in ubuntu.

More information about the Ubuntu-server-bugs mailing list