[Bug 481203] [NEW] Hardy 8.04.3 openssh does not forward X11 always cannot open display

Jose L. VG josvazg+launchpad at gmail.com
Thu Nov 12 09:40:42 GMT 2009


Public bug reported:

The client machine is a Karmic koala that DOES ssh forwarding ok against
othe servers (mostly fedoras or Ubuntu Hardy desktops) [The problem IS
NOT ON THE client side, as it does the jobs correctly against other
servers]

The failing (ssh) server machine is a Ubuntu Hardy LTS "SERVER edition"
(NOT desktop) freshly installed from the CD (not upgraded)

The xauth package is installed and created the .Xauthority user file
becuase X11Forwarding is already enabled in sshd_config on that server.

The local port 6010 is listening for conntections (you can telnet
localshot 6010 to it) AND the DISPLAY variable is correctly set to
"localhost:10.0" BUT...

IT STILL DOES NOT WORK!!!

gedit and xhost complain:
$ gedit
cannot open display: 
Run 'gedit --help' to see a full list of available command line options.

admin at madcvd01lnx:~$ gedit --display=$DISPLAY
cannot open display: localhost:10.0
Run 'gedit --help' to see a full list of available command line options.

admin at madcvd01lnx:~$ xhost
xhost:  unable to open display "localhost:10.0"

Do I need to install something more on the SERVER LTS edition to enable X11forwarding aprt from xauth and the sshd_config?
[Remember that this is not a Hardy desktop, but a server with much less installed packages by default]

** Affects: openssh (Ubuntu)
     Importance: Undecided
         Status: New

-- 
Hardy 8.04.3 openssh does not forward X11 always  cannot open display
https://bugs.launchpad.net/bugs/481203
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to openssh in ubuntu.



More information about the Ubuntu-server-bugs mailing list