[Bug 456806] Re: mountall vomits a shell onto virtual console when you run vi

Nicholas Campion campnic at gmail.com
Wed Nov 11 04:27:25 GMT 2009

I am seeing this issue as well.  The final messages I see on my vanilla
server install after boot are:

One or more of the mounts listed in /etc/fstab cannot yet be mounted:
(ESC for recovery shell)
swap: waiting for /dev/mapper/cryptswap1

This is a fully upgraded but completely default (not additional software
selected) install of 9.10 with encrypted user folders.

The reason I wanted to add a comment is that I was experiencing some
other behaviors that might be related.  The first thing I tried to do
was to apt-get update / upgrade to see if that fixed the mountall error
and I couldn't sudo because my password got rejected.  When I would type
the password and hit enter, the prompt would not respond, so I'd hit
enter again, and it would respond and say the password was incorrect.
It was as if the first enter keystroke was lost.

I tried to ssh into another box to see if that was working and had my
password rejected by the remote system.  Again, the password prompt
would act as though my first enter keystroke was lost.  And then my
password was rejected on a system I could access from another terminal.

The shell on the system works well as long as I don't hit escape (the
mountall recovery shell problem)  and as long as I don't try to enter a
password.  I haven't yet determined that they are directly related but
thought this might catch someone's eye.

mountall vomits a shell onto virtual console when you run vi
You received this bug notification because you are a member of Ubuntu
Server Team, which is a subscriber of a duplicate bug.

More information about the Ubuntu-server-bugs mailing list