[Bug 469419] [NEW] KVM machines became corrupted after reboot

Tomasz Nowak Tomasz.NowakTN at gmail.com
Sun Nov 1 20:39:41 GMT 2009

Public bug reported:

Binary package hint: qemu-kvm

  I've just upgraded my Linux to Kubuntu 9.10 (i386).
  I'm using  KVM and virt-manager on it.
  Unfortunately my VM boxes became corrupted after I install new software on these or create some files.

  Here is the VM definition:

$ virsh dumpxml ubuntu
Connecting to uri: qemu:///system               
<domain type='kvm' id='27'>                     
    <type arch='i686' machine='pc-0.11'>hvm</type>
    <boot dev='hd'/>
  <clock offset='utc'/>
    <disk type='file' device='disk'>
      <source file='/dev/mapper/vm-ubuntu'/>
      <target dev='hda' bus='ide'/>
    <disk type='file' device='cdrom'>
      <source file='/home/tomnowak/Desktop/Software/linux/ubuntu/ubuntu-9.10-server-i386.iso'/>
      <target dev='hdc' bus='ide'/>
    <interface type='network'>
      <mac address='00:50:56:11:11:11'/>
      <source network='default'/>
      <target dev='vnet0'/>
      <model type='e1000'/>
    <input type='mouse' bus='ps2'/>
    <graphics type='vnc' port='5911' autoport='no' listen=''/>
      <model type='vga' vram='8192' heads='1'/>
  <seclabel type='dynamic' model='apparmor'>

I'm trying to install Ubuntu Server Edition 9.10 but after a few reset
there is a problem with swap partition on the screen while booting:

One or more of the mounts listed in /etc/fstab cannot yet be mounted:
(ESC for recovery shell)
swap: waiting for UUID=903d9649-0587-45b1-a501-8c02d71f43fc

Then when trying to recreate swap on /dev/sda5 I get:

root at ubuntu:~# fdisk -l

Disk /dev/sda: 10.7 GB, 10737418240 bytes
255 heads, 63 sectors/track, 1305 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000dd054

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        1243     9984366   83  Linux
/dev/sda2            1244        1305      498015    5  Extended
/dev/sda5            1244        1305      497983+  82  Linux swap / Solaris
root at ubuntu:~# swapon -a
swapon: cannot find the device for UUID=903d9649-0587-45b1-a501-8c02d71f43fc
root at ubuntu:~# swapon /dev/sda5
swapon: /dev/sda5: read swap header failed: Invalid argument
root at ubuntu:~# mkswap /dev/sda5
Setting up swapspace version 1, size = 497976 KiB
no label, UUID=38153005-9024-4eee-b1b9-99c3b0cfee62
root at ubuntu:~# swapon /dev/sda5
swapon: /dev/sda5: read swap header failed: Invalid argument

Later I tried to install some software:
# apt-get install azureus
and during the package installation I saw strange characters on the screen and everything stopped working.
After a reset system was dead - the grub stopped booting - it seems my entire virtual disk became totally corrupted.
GRUB loading.
error: invalid arch independent ELF magic
grub rescue>

The above message is almost every time different

I've tried different disk types: ide, scsi, virtio - always the same.
Also the same when trying to install Kubuntu 9.10 under KVM.

** Affects: qemu-kvm (Ubuntu)
     Importance: Undecided
         Status: New

KVM machines became corrupted after reboot
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to qemu-kvm in ubuntu.

More information about the Ubuntu-server-bugs mailing list