[Bug 352446] [NEW] libtomcat6-java depends on libecj-java

stephen mulcahy smulcahy at atlanticlinux.ie
Tue Mar 31 16:01:38 BST 2009

Public bug reported:

Binary package hint: tomcat6

libtomcat6-java depends on libecj-java which in turn installs gcj.

In practice, if I have sun-java6-jdk installed and then install tomcat6

sudo aptitude -R install tomcat6

which doesn't pull

ecj-gcj libecj-java-gcj

as dependencies, everything works fine and my environment continues using sun java6 (which I need
for my project).

Can we rectify the dependencies here to avoid this implicit dependency
on gcj?

** Affects: tomcat6 (Ubuntu)
     Importance: Undecided
         Status: New

libtomcat6-java depends on libecj-java
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to tomcat6 in ubuntu.

More information about the Ubuntu-server-bugs mailing list