[Bug 316957] Re: package mysql-server-5.1 5.1.30-2ubuntu1 failed to install/upgrade: 子进程 post-installation script 返回了错误号 1

ShaunS shaun at saintsi.co.uk
Sat Jan 17 22:40:00 GMT 2009


Hi,

I am still getting this bug as of 17/01/2009.

My workaround is to install Amarok. Install fails with MySQL 5.1 start
error.

>From the my command-line:

shaun at kubuntu:~$ sudo mysqld
mysqld: Table 'mysql.plugin' doesn't exist
090117 22:24:56 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
090117 22:24:57  InnoDB: Started; log sequence number 0 46409
090117 22:24:57 [ERROR] mysqld: unknown option '--skip-bdb'
090117 22:24:57 [ERROR] Aborting

090117 22:24:57  InnoDB: Starting shutdown...
090117 22:24:58  InnoDB: Shutdown completed; log sequence number 0 46409
090117 22:24:58 [Note] mysqld: Shutdown complete


I then edit /etc/mysql/my.cnf and comment out the line:
skip-bdb

I then get the error:

shaun at kubuntu:~$ sudo mysqld
mysqld: Table 'mysql.plugin' doesn't exist
090117 22:26:07 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
090117 22:26:07  InnoDB: Started; log sequence number 0 46409
090117 22:26:07 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.host' doesn't exist

If I now install a package (any package) and apt fixes the MySQL problem
(I dont know how exactly) and all is well.

Hope this helps,
Shaun

-- 
package mysql-server-5.1 5.1.30-2ubuntu1 failed to install/upgrade: 子进程 post-installation script 返回了错误号 1
https://bugs.launchpad.net/bugs/316957
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to mysql-dfsg-5.1 in ubuntu.



More information about the Ubuntu-server-bugs mailing list