[Bug 305454] Re: 'mount error 13 = Permission denied' when user mounts cifs (sudo works!)

Helzibah helen.m.gray at gmail.com
Wed Jan 7 17:54:58 GMT 2009


Seconded.  I'm also running Ubuntu 8.10 (with smbclient version 3.2.3)
and experienced a similar problem recently.  I have three entries like
the following (accessing different folders on the server) in my fstab:

//helios/public /media/helios-public   cifs    defaults,noatime,auto   0
0

Previously this worked fine, now I get some very strange behaviour.
With the line above, I get a password request, and then, regardless of
what I type:

mount error 13 = Permission denied
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

I tried adding the guest option:

//helios/public /media/helios-public   cifs
defaults,noatime,auto,guest   0   0

This doesn't ask for a password, as expected, but returns the same
error.  Not to be defeated, I tried adding a username instead:

//helios/public /media/helios-public   cifs
defaults,noatime,auto,username=guest   0   0

This asks for a password as before, yet bizarrely it accepts whatever I
type and mounts the share.  So my temporary fix is to add the password
option to my fstab with a random word:

//helios/public /media/helios-public   cifs
defaults,noatime,auto,username=guest,password=foo   0   0

Now my shares are mounted fine without user input, even though both the
username and password do not exist.  This seems to work fine as a
temporary fix for unprotected shares.

-- 
'mount error 13 = Permission denied' when user mounts cifs (sudo works!)
https://bugs.launchpad.net/bugs/305454
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to samba in ubuntu.



More information about the Ubuntu-server-bugs mailing list