[Bug 282298] Re: [SRU] Intrepid: No Access to NAS (samba<=2.2.x) shares any more

Grobot grobottom at pl.net
Tue Jan 6 09:08:42 GMT 2009

 I have read through this bug with some interest and tried to add the libsmbclient suggested above and was told a newer version was already installed...  
I have a similar problem as reported initially and a real Linux Noob..  I was hoping the patch downloaded today would fix things but no joy..

gary at gary-laptop:~$ smbclient -V
Version 3.2.3
My proceedings are as follows in a shell

gary at gary-laptop:~$ smbclient //NASSTORE/PUBLIC -W SHAZ -U gary
Enter gary's password: 
Domain=[ȇ] OS=[] Server=[���]
smb: \> ls
cli_list_new: Error: unable to parse name from info level 1
Segmentation fault
gary at gary-laptop:~$

the system logs this
Jan  6 21:58:53 gary-laptop kernel: [ 3969.498048] smbclient[6183]: segfault at 0 ip b7ad42c3 sp bfed5f3c error 4 in libc-2.8.90.so[b7a5d000+158000]

I can mkdir and cd etc but no access to file listings. 
Nautilus just re-directs itself to my home page.

my NAS is a NexStarLX with the latest firmware Version installed which
is like dated 2006-10-9 which doesnt really fill me with much warmth but
I do knw this drive did work with a previous debian installation I had.
not sure of the version.  Funny old thing is the Solaris installation I
tried also failed to access the NAS.  (I have been trying out versions
untill I found one I like.) (Ubuntu 8.10 seems to be the winner bar this
samba problem :( )

I havent tried the gvs stuff yet.. but will ry and pick through it.
Happy New year to you all.  

[SRU] Intrepid: No Access to NAS (samba<=2.2.x) shares any more
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to samba in ubuntu.

More information about the Ubuntu-server-bugs mailing list