[Bug 497196] [NEW] ietadm not in the eucalyptus user's path

Dustin Kirkland dustin.kirkland at gmail.com
Tue Dec 15 22:49:50 GMT 2009

Public bug reported:

ietadm is in /usr/sbin/ietadm, which is not in the eucalyptus user's
default PATH.

This is causing the following errors in /var/log/eucalyptus/cloud-error.log:
com.eucalyptus.util.EucalyptusCloudException: ietadm not found: Is iscsitarget installed?
        at edu.ucsb.eucalyptus.storage.ISCSIManager.checkPreconditions(ISCSIManager.java:64)
        at edu.ucsb.eucalyptus.storage.LVM2Manager.checkPreconditions(LVM2Manager.java:145)
        at com.eucalyptus.bootstrap.BlockStorageBootstrapper.load(BlockStorageBootstrapper.java:99)
        at com.eucalyptus.bootstrap.SystemBootstrapper.load(SystemBootstrapper.java:180)
16:41:00 [SystemUtil:main]  ERROR com.eucalyptus.util.ExecutionException: ///usr/lib/eucalyptus/euca_rootwrap ietadm --version

eucalyptus at aussie:~$ echo $PATH

This can be solved either by adding /usr/sbin to eucalyptus' PATH, or by
fully qualifying the ietadm binary in the eucalyptus source code.

Either way, this should be solved programmatically for UEC.

** Affects: eucalyptus (Ubuntu)
     Importance: Medium
         Status: Triaged

** Changed in: eucalyptus (Ubuntu)
       Status: New => Triaged

** Changed in: eucalyptus (Ubuntu)
   Importance: Undecided => Medium

ietadm not in the eucalyptus user's path
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to eucalyptus in ubuntu.

More information about the Ubuntu-server-bugs mailing list