[Bug 270570] [NEW] cifs mounts and unmounts properly for a day or so, then hangs on future mounts

Dan VerWeire dverweire at gmail.com
Mon Sep 15 16:34:27 BST 2008


Public bug reported:

Binary package hint: samba

I have a script that every hour mounts a share using CIFS, copies some
files, then unmounts the share.  This works for a day or so, then I am
unable to mount any CIFS shares.  I cannot rmmod cifs. In order to mount
shares again, I must reboot my machine.

kernel 2.6.26 on Hardy
ps aux | grep cifs shows a bunch of /sbin/mount.cifs processes that are in state D (Uninterruptible sleep)
    -Also, [cifsd] is in state D
/etc/mtab will still contain the mounted shares
/proc/mounts does not list the shares
/proc/fs/cifs/DebugData contains:

Display Internal CIFS Data Structures for Debugging
---------------------------------------------------
CIFS Version 1.53
Active VFS Requests: 20
Servers:
entry for 192.168.100.x not fully displayed
        TCP status: 2
        Local Users To Server: 0 SecMode: 0x3 Req On Wire: 0
MIDs:

2) Name: 192.168.100.x  Domain: MYDOMAIN Mounts: 0 OS: Windows 5.0
        NOS: Windows 2000 LAN Manager   Capability: 0xf3fd
        SMB session status: 1   TCP status: 2
        Local Users To Server: 0 SecMode: 0x3 Req On Wire: 0
MIDs:

3) Name: 192.168.100.x2  Domain: MYDOMAIN Mounts: 0 OS: Windows 5.0
        NOS: Windows 2000 LAN Manager   Capability: 0xf3fd
        SMB session status: 1   TCP status: 2
        Local Users To Server: 0 SecMode: 0x3 Req On Wire: 0
MIDs:

Shares:
1)  Uses: 0 DevInfo: 0x0 Attributes: 0x0
PathComponentMax: 0 Status: 0 type: 0
2)  Uses: 0 DevInfo: 0x0 Attributes: 0x0
PathComponentMax: 0 Status: 0 type: 0
3)  Uses: 0 DevInfo: 0x0 Attributes: 0x0
PathComponentMax: 0 Status: 0 type: 0
4)  Uses: 0 DevInfo: 0x0 Attributes: 0x0
PathComponentMax: 0 Status: 0 type: 0
5)  Uses: 0 DevInfo: 0x0 Attributes: 0x0
PathComponentMax: 0 Status: 0 type: 0
6)  Uses: 0 DevInfo: 0x0 Attributes: 0x0
PathComponentMax: 0 Status: 0 type: 0
7)  Uses: 0 DevInfo: 0x0 Attributes: 0x0
PathComponentMax: 0 Status: 0 type: 0
8)  Uses: 0 DevInfo: 0x0 Attributes: 0x0
PathComponentMax: 0 Status: 0 type: 0
9)  Uses: 0 DevInfo: 0x0 Attributes: 0x0
PathComponentMax: 0 Status: 0 type: 0
10)  Uses: 0 DevInfo: 0x0 Attributes: 0x0
PathComponentMax: 0 Status: 0 type: 0
11)  Uses: 0 DevInfo: 0x0 Attributes: 0x0
PathComponentMax: 0 Status: 0 type: 0
12)  Uses: 0 DevInfo: 0x0 Attributes: 0x0
PathComponentMax: 0 Status: 0 type: 0
13)  Uses: 0 DevInfo: 0x0 Attributes: 0x0
PathComponentMax: 0 Status: 0 type: 0
14)  Uses: 0 DevInfo: 0x0 Attributes: 0x0
PathComponentMax: 0 Status: 0 type: 0
15)  Uses: 0 DevInfo: 0x0 Attributes: 0x0
PathComponentMax: 0 Status: 0 type: 0
16)  Uses: 0 DevInfo: 0x0 Attributes: 0x0
PathComponentMax: 0 Status: 0 type: 0

** Affects: samba (Ubuntu)
     Importance: Undecided
         Status: New

-- 
cifs mounts and unmounts properly for a day or so, then hangs on future mounts
https://bugs.launchpad.net/bugs/270570
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to samba in ubuntu.



More information about the Ubuntu-server-bugs mailing list