[Bug 290747] [NEW] Intrepid X11 Forwarding Not Working

Ben pumrum at gmail.com
Wed Oct 29 15:15:56 GMT 2008

Public bug reported:

Binary package hint: ssh

I'm using the Intrepid Release Candidate CD. The exact problem detailed
below also exists on 8.04, 8.04.1, and all of the Intrepid Alpha
releases. The problem described below does NOT exist on 7.10 (Gutsy).

I've been using Gutsy for almost a year to connect to a Solaris 10 box
running an X server. I type 'xhost +' then 'ssh -X user at server'. When I
type 'echo $DISPLAY' in the SSH session, it shows I can
then type 'firefox' and after a few seconds, a firefox X11 window will
pop up. This is just one example, I use it for several X programs on the
Solaris server. When I use my Gutsy laptop to connect to the Solaris
server, everything works as expected. I can also connect from CygWin and
MING clients on Windows.

I am now booting into a fresh Intrepid Release Candidate installation. I
type 'xhost +' then 'ssh -X user at server'. I check my display variable in
the SSH session and it's fine, the same as on the Gutsy server. However,
when I go to run an X program, I get an X11 error. The actual error
varies depending on the program I run, but they all boil down to the
same root message: "Gtk-WARNING **: cannot open display:" or "Exception
in thread "main" java.lang.InternalError: Can't connect to X11 window
server using '' as the value of the DISPLAY variable."

Ive tried changing the display variable to:


nothing seems to work. Any thoughts on how to fix this in Intrepid? Any
idea what broke going from Gutsy to Intrepid (well, it broke first in
Hardy, but continues to be broken in Intrepid)?

I will attach several outputs. I have attached a log of my SSH session
to this post. It shows what happens when I run:

xhost +
ssh -vvvX user at server
<login with user and pass>
<x11 forwarding error>

the same exact process on Gutsy will start the X11 program.

** Affects: openssh (Ubuntu)
     Importance: Undecided
         Status: New

Intrepid X11 Forwarding Not Working
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to openssh in ubuntu.

More information about the Ubuntu-server-bugs mailing list