[Bug 278495] Re: megatec_usb does'nt detect ups

Arnaud Quette aquette.dev at gmail.com
Wed Oct 29 14:17:45 GMT 2008


2008/10/29  <lasaine at lvk.cs.msu.su>:
> Hi Arnaud,

Hi Alexander,

thanks for your sum up.

> On Mon, Oct 27, 2008 at 04:30:20PM +0100, Arnaud Quette wrote:
>> 2008/10/27 Chuck Short <chuck.short at canonical.com>:
>> > Arnaud,
>> >
>> > Any thought about this? Its a regression from 2.2.1.
>>
>> not yet! @Alex: any idea on your side (change of the default driver or
>> something alike)
>> this seems to be a timing or reading problem according to the "short read" msg
>>
>> Artin, can you also post the debug drivers's output of 2.2.1 for comparing?
>
> First of all I want to note that there is no phoenix subdriver in both
> the official 2.2.1 and 2.2.2 sources. If my memory serves me well I once
> sent a patch to Chuck that added it and some other stuff from the trunk.
> So the driver in 2.2.1 package was mostly the same as in the trunk
> because of this patch. It seems to me that something happened with this
> patch in 2.2.2 package (because 2.2.2 still lacks the new phoenix
> subdriver). So you see, it was actually a downgrade.
>
> The thing that confused me at first is that the 2.2.2 version log tells
> that the agiler subdriver is used. But this is just an error in log
> text. In fact it uses agiler_old subdriver which doesn't work with some
> models (like Artin's). Since this is already an official release, I
> can't fix it.

right, I only checked the trunk. looking at a pristine 2.2.2, there is
only agiler + old and krauler
the trunk includes the phoenix sub driver.

Note: just to clarify the situation, since it isn't clear to me (and
possibly others)
in the trunk, the 0x06da:0x0003 is listed with the phoenix_subdriver
agiler_old subdriver
in 2.2.2, it's listed with the agiler_old subdriver

what is the right one and what is the right fix? This is the short run
focus.

Also note that we can always extract a patch that only applies to (ie)
the Debian or Ubuntu package, without the need to throw out a new NUT
release...

> @Arnaud: when will be the next? :)

the next is 2.4, and the roadmap is under refection...
still scheduled for christmas.

> I think phoenix subdriver should be there.

ok

thanks,
-- Arnaud

-- 
megatec_usb does'nt detect ups
https://bugs.launchpad.net/bugs/278495
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to nut in ubuntu.



More information about the Ubuntu-server-bugs mailing list