[Bug 120375] Re: cannot boot raid1 with only one disk

agent 8131 agent.8131 at infotage.net
Fri Oct 10 06:58:43 BST 2008

I think it's time for some tough love.  No one would be taking the time
to comment on this if they didn't want to see Ubuntu Server be a better
product.  I personally feel this is a significant issue for because it
demonstrates Canonical's interest in supporting an LTS release and
seriousness about becoming a presence in the server market.  I know it
can be difficult when people are lambasting a product you've put a lot
of time into, believe me, I got more than my fair share of that this
week.  However, sometimes you have to step back and realize that your
product quality has been lower than many people expect and you have to
either step up or risk losing more customers.  Make no mistake, this bug
has lost a lot of sysadmins, some of whom had to fight hard to get
Ubuntu onto servers in their workplaces in the first place.  I was one
of them, and I know a few more personally.  I pitched that it made sense
to have Ubuntu on the Server because of the benefits of the LTS release,
including the longer support time and the large community that
contributes to Ubuntu, therefore leading to more bugs being found and
resolved.  However, I doubt I will be able to propose Ubuntu again until
version 10.04.  If this bug were to be resolved in 8.04.2 I might at
least start pitching it next year, barring any other bugs of this level
of severity.

To respond to Steve Langasek, while I understand that a lot of these
emails are not terribly useful, this bug is exactly what the SRU team is
supposed to be addressing.  There have been many proposed fixes in this
thread and 8 patches uploaded.  Do any of them work correctly?  Well
that is the question, but it's inaccurate to state that this bug does
not contain proposed fixes.  Furthermore this fits the SRU criteria of
being a high impact bug representing a severe regression from earlier
versions and one which also may lead to a loss of user data.  When the
average user is confronted with the initramfs shell during a drive
failure I suspect they have the potential to do serious damage to their
file systems in an attempt to fix the problem.

I don't feel it's possible for me to understate the severity of this bug
and how badly sysadmins are going to react when they encounter it or
read about it.  It is certainly not the kind of bug one can dismiss in
an LTS release if LTS is to say anything about quality, and hence
suggestions to upgrade to Intrepid, while acceptable to a home user
building a server, are not going to be acceptable in the workplace.  If
this is a market segment that Ubuntu Server is catered to than this
issue needs to be addressed.  If on the other hand Ubuntu Server is
meant merely for enthusiasts with their home file servers than the
solution should be to make sure that goal is clearly articulated.

To keep us focused on the work at hand and to avail myself of the
opportunity that having this number of people working for fix this bug
represents I'll say that I've tried a number of solutions on this page
but none have been satisfactory.  I tried changing the udev rule as
suggested above (see Plnt 2007-12-25)  but got the same results that
have been reported: I can get the system to boot any time the disk is
degraded but at the expense that it boots degraded sometimes even when
the disks are fine.  This is the setting on my remaining Ubuntu servers
(which will be migrated to Debian in the near future).  This option is
suboptimal but better than the default behavior.  I would say that the
ideal (and expected) behavior is for the system to boot in the case of a
degraded array by default, with an option to turn that off if the
sysadmin chooses.  For those with Ubuntu servers, assuming this never
gets fixed, I think an initramfs  script (in /etc/initramfs-
tools/scripts/)  that anyone could copy onto their server might be
ideal.  Alternatively patching the mdadm udev script to try and start
with --no-degraded and on failure use --run might also be an option.  I
have a server I may be able to user for testing but if anyone has a
script to start with that would be great.

cannot boot raid1 with only one disk
You received this bug notification because you are a member of Ubuntu
Server Team, which is a subscriber of a duplicate bug.

More information about the Ubuntu-server-bugs mailing list