[Bug 286828] Re: CIFS share broken after upgrade from 8.04 -> 8.10

flanker flanker at gmail.com
Mon Nov 3 07:38:36 GMT 2008

Confirming Aron's recent report for Kubuntu 8.10.  I'm running from the
Intrepid Live CD right now, and experiencing the issue others have
reported with being able to read/create, but not modify/overwrite files
on the share.  I've tried the nounix option (below) as well as the
LinuxExtensionsEnabled = 0 option described above and they both give the
same results.  The server is running the packaged version of Samba3 for
OpenWRT (more details below).  This issue is of high importance to me
(upgrade show-stopper), and I'd be happy to provide any additional
information required---just let me know.

Mount parameters:
ubuntu at ubuntu:~$ tail -n 1 /etc/fstab 
//myserver/media /home/ubuntu/sharetest cifs rw,uid=999,gid=999,credentials=/etc/credentialsfile,nounix 0 0

A little test demonstrating what works: create, append, remove, but not overwrite?
ubuntu at ubuntu:~$ sudo mount sharetest/
ubuntu at ubuntu:~$ cd sharetest/
ubuntu at ubuntu:~/sharetest$ echo happy > birthday
ubuntu at ubuntu:~/sharetest$ echo happier >> birthday
ubuntu at ubuntu:~/sharetest$ cat birthday
ubuntu at ubuntu:~/sharetest$ echo happiest > birthday
bash: birthday: Not a directory
ubuntu at ubuntu:~/sharetest$ cat birthday
ubuntu at ubuntu:~/sharetest$ rm birthday
ubuntu at ubuntu:~/sharetest$ ls birthday
ls: cannot access birthday: No such file or directory

Version info:
ubuntu at ubuntu:~/sharetest$ cat /proc/fs/cifs/DebugData
Display Internal CIFS Data Structures for Debugging
CIFS Version 1.54
Active VFS Requests: 0
1) Name:  Domain: MYDOMAIN Mounts: 1 OS: Unix
        NOS: Samba 3.0.24       Capability: 0x80f3fd
        SMB session status: 1   TCP status: 1
        Local Users To Server: 1 SecMode: 0x3 Req On Wire: 0

1) \\myserver\media Uses: 2 Type: NTFS DevInfo: 0x0 Attributes: 0xb
PathComponentMax: 255 Status: 1 type: 0

ubuntu at ubuntu:~/sharetest$ smbclient -V && uname -a
Version 3.2.3
Linux ubuntu 2.6.27-7-generic #1 SMP Fri Oct 24 06:42:44 UTC 2008 i686 GNU/Linux

Aside: Has anyone tried downgrading to/pinning an older smbfs package?  Maybe the ones reported as working from 8.04?

CIFS share broken after upgrade from 8.04 -> 8.10
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to samba in ubuntu.

More information about the Ubuntu-server-bugs mailing list