[Bug 200308] Re: Upgrade doesnt work if using mysql dict types

Scott Kitterman ubuntu at kitterman.com
Tue Mar 11 01:26:31 GMT 2008

I'm a little confused by your configuration.  You have:

alias_database = mysql:/etc/postfix/mysql_virtual_alias_maps
alias_maps = mysql:/etc/postfix/mysql_virtual_alias_maps


virtual_alias_maps = mysql:/etc/postfix/mysql_virtual_alias_maps

I don't think you need both of these.  I suspect that if you restore
alias_database and alias_maps to the Ubuntu default values:

alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases

your system would still work correctly and the problem would go away.
I'm guessing that you only want mysql lookups for your virtual domains.
The way you have it now, it's looked up for all domains.  I'm not
certain of this, so please try the change and see if it still does what
you need.  If it does, we can maybe go through downgrading and upgrading
and see if this is the root of the issue.

Upgrade doesnt work if using mysql dict types
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to postfix in ubuntu.

More information about the Ubuntu-server-bugs mailing list