[Bug 230016] Re: [intrepid] Rebuild with perl 5.10

John Vivirito gnomefreak at gmail.com
Sun Jun 1 13:57:09 BST 2008

There has to be more to it than just depends on perl. irssi depends on perl and is still not able to be installed due to perl. upgrade output is from intrepid system that i didnt upgrade perl and freinds since it removes irssi.
The intall output is from intrepid chroot since irssi wasnt installed. It seems not all perl is done so building against some perl isnt really doing much good and they will need to be respun once perl is done upgrading.  I'm not sure about the other packages. Here is the output below:

sudo apt-get upgrade
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  bind9-host cpp cpp-4.2 dnsutils g++ g++-4.2 gcc gcc-4.2 gcc-4.2-base
  libaudio-cd-perl libcairo-perl libcompress-raw-zlib-perl
  libcompress-zlib-perl libdigest-sha1-perl libgettext-ruby1.8 libglib-perl
  libgnome2-canvas-perl libgnome2-perl libgnome2-vfs-perl libgtk2-perl
  libhtml-parser-perl libio-compress-zlib-perl liblocale-gettext-perl
  libnet-dbus-perl libnet-dns-perl libnetaddr-ip-perl libpurple0 libsnmp15
  libsocket6-perl libstdc++6-4.2-dev libterm-readkey-perl
  libterm-readline-gnu-perl libtext-charwidth-perl libtext-iconv-perl
  libxml-parser-perl perl perl-base perl-modules pidgin pidgin-plugin-pack
  poppler-utils xchat xchat-common xfce4-panel xfce4-terminal xfce4-utils
  xfce4-verve-plugin xfdesktop4 xfdesktop4-data

sudo apt-get install irssi
(intrepid)gnomefreak at Development:~$ sudo apt-get install irssi
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  irssi: Depends: libperl5.8 (>= 5.8.8) but it is not going to be installed
         Depends: perlapi-5.8.8 but it is not installable
E: Broken packages

Here is output of apt-cache policy for the packages that irssi depends

(intrepid)gnomefreak at Development:~$ policy libperl5
W: Unable to locate package libperl5
(intrepid)gnomefreak at Development:~$ policy libperl5.0
W: Unable to locate package libperl5.0
(intrepid)gnomefreak at Development:~$ policy perlapi-5.8.8 
  Installed: (none)
  Candidate: (none)
  Version table:

Is there a reason we are depending on packages we dont have in repos?
the above perl packages are not in Hardy either. Please post the bugs
that are filed separate on this bug so we know where they can be found

[intrepid] Rebuild with perl 5.10
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to openldap2.3 in ubuntu.

More information about the Ubuntu-server-bugs mailing list