[Bug 251469] [NEW] samba nightmare

codeslinger codeslinger at compsalot.com
Thu Jul 24 13:03:46 BST 2008

Public bug reported:

Binary package hint: samba

Ubuntu 8.0.4 Hardy Heron Desktop

I have spent *DAYS* trying to get this to work!!!
now my ubuntu system is so badly hosed it looks like I will have to restore from backup.

all I did was uninstall samba and cups and then attempt to reinstall them.
I did this because THEY DONT FRIGGIN WORK!!!!!!!!!!!!

all I want is for the most basic and fundamental of things....

I want/need to run ubuntu in a mixed environment with windows 98 and
windows XP computers.  I want and need for those computers to be able to
access files and *printers* that are on the ubuntu computer.  Why is
that so difficult?

I am not a newbe, I know how to check the box that says to "enable
sharing" and to "share this printer".  too bad it doesn't actually
work.....  have you tried it on a clean install of ubuntu????

The corruption problems started after I installed gsambad and  system-
config-samba(?)    after that I could no longer open the printing config
program on the system/admin menu.  after fiddling around for awhile I
resorted to removal of samba and cups and the attempt to reinstall


I have tried a lot of linux distros over the years.  and I swear by
linux for servers.  but on the desktop it is a whole other story of
endless promise and disappointment.  So far ubuntu is the closest I have
come to a total linux desktop success, but the fact that it can not out-
of-the-box interoperate with other MS Windows computers is a *MAJOR*
design flaw.   It should not be necessary to install additional software
in order to share a printer, it should not be required to read 100+
pages of highly technical docs to get samba file and print sharing to
work.  every other distro I have tried has successfully done printer and
file sharing  (sometimes with a battle, but always with a success),
where other distros have fallen down is on krappy sound, video and
browser support.  Ubuntu on the other hand is the first distro I have
found that has great!!! sound and , video and browser support, but where
it falls flat on it's face is the krappy printer and file sharing *total
lack* of support.

Yes, I have Read The Fine Manual, I have checked the appropriate boxes,
I have installed the appropriate packages, but after *DAYS* of effort it
still does not work.  I am not an idiot, but krap like this sure makes
me feel like one.  I tell you what though, if I can't figure it out,
with as much time and knowledge and experience as I have, then it is a
sure bet that casual end users of computers are sure as heck not even
going to be close to being able to use it.

I want Ubuntu to be a success, You want Ubuntu to be a success, so please fix this mess!

ProblemType: Package
Architecture: i386
Date: Thu Jul 24 04:21:43 2008
DistroRelease: Ubuntu 8.04
ErrorMessage: subprocess post-installation script returned error exit status 1
Package: samba-common 3.0.28a-1ubuntu4.4
PackageArchitecture: i386
SourcePackage: samba
Title: package samba-common 3.0.28a-1ubuntu4.4 failed to install/upgrade: subprocess post-installation script returned error exit status 1
Uname: Linux 2.6.24-19-generic i686

** Affects: samba (Ubuntu)
     Importance: Undecided
         Status: New

** Tags: apport-package

samba nightmare
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to samba in ubuntu.

More information about the Ubuntu-server-bugs mailing list