[Bug 310019] [NEW] package mysql-server None [modified: /var/lib/dpkg/info/mysql-server.list] failed to install/upgrade: subprocess pre-installation script returned error exit status 1

Scott Gilmore georider at gmail.com
Sat Dec 20 16:58:30 GMT 2008


Public bug reported:

This occured while installing mythtv through 'apt-get install mythtv' on
Ubuntu 8.10

Additional info:

sgilmore at fry:~$ apt-cache policy mysql-server
mysql-server:
  Installed: (none)
  Candidate: 5.0.67-0ubuntu6
  Version table:
     5.0.67-0ubuntu6 0
        500 http://us.archive.ubuntu.com intrepid/main Packages

Running 'sudo apt-get install mysql-server' after the failure seems to
work around the problem. The running 'sudo dpkg-reconfigure mythtv-
database' as the mythtv installation was probably not completed.

Sorry, I don't submit many bug reports (mainly because the developers of
Ubuntu seem to know what they are doing) so I hope this is not too much
info.


Here is more info from the terminal:


***************************************** TERMINAL DUMP *******************************

sgilmore at fry:~$ sudo apt-get install mythtv
[sudo] password for sgilmore: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libdbd-mysql-perl libfame-0.9 libglib1.2ldbl libgtk1.2 libgtk1.2-common
  liblzo1 libmyth-0.21-0 libmyth-perl libnet-upnp-perl libpvm3 libqt3-mt-mysql
  libsox-fmt-alsa libsox-fmt-base libsox0 mjpegtools mysql-client
  mysql-client-5.0 mysql-server mysql-server-5.0 mythtv-backend mythtv-common
  mythtv-database mythtv-frontend mythtv-theme-blootube
  mythtv-theme-blootube-osd mythtv-theme-blootube-wide
  mythtv-theme-blootubelite-wide mythtv-theme-glass-wide mythtv-theme-gray-osd
  mythtv-theme-isthmus mythtv-theme-iulius mythtv-theme-iulius-osd
  mythtv-theme-minimalist-wide mythtv-theme-mythbuntu mythtv-theme-mythcenter
  mythtv-theme-mythcenter-wide mythtv-theme-neon-wide
  mythtv-theme-projectgrayhem mythtv-theme-projectgrayhem-osd
  mythtv-theme-projectgrayhem-wide mythtv-theme-retro mythtv-theme-retro-osd
  mythtv-theme-titivillus mythtv-theme-titivillus-osd mythtv-themes
  mythtv-transcode-utils ntp pvm pwgen sox toolame transcode transcode-doc
Suggested packages:
  libsox-fmt-all mpeg2dec a52dec mysql-doc-5.0 tinyca mailx mythtv-doc mythweb
  xmltv-util mythmusic mythweather mythgallery mythvideo mythgame mythstream
  mytharchive ntp-doc xvid4conf
The following NEW packages will be installed:
  libdbd-mysql-perl libfame-0.9 libglib1.2ldbl libgtk1.2 libgtk1.2-common
  liblzo1 libmyth-0.21-0 libmyth-perl libnet-upnp-perl libpvm3 libqt3-mt-mysql
  libsox-fmt-alsa libsox-fmt-base libsox0 mjpegtools mysql-client
  mysql-client-5.0 mysql-server mysql-server-5.0 mythtv mythtv-backend
  mythtv-common mythtv-database mythtv-frontend mythtv-theme-blootube
  mythtv-theme-blootube-osd mythtv-theme-blootube-wide
  mythtv-theme-blootubelite-wide mythtv-theme-glass-wide mythtv-theme-gray-osd
  mythtv-theme-isthmus mythtv-theme-iulius mythtv-theme-iulius-osd
  mythtv-theme-minimalist-wide mythtv-theme-mythbuntu mythtv-theme-mythcenter
  mythtv-theme-mythcenter-wide mythtv-theme-neon-wide
  mythtv-theme-projectgrayhem mythtv-theme-projectgrayhem-osd
  mythtv-theme-projectgrayhem-wide mythtv-theme-retro mythtv-theme-retro-osd
  mythtv-theme-titivillus mythtv-theme-titivillus-osd mythtv-themes
  mythtv-transcode-utils ntp pvm pwgen sox toolame transcode transcode-doc
0 upgraded, 54 newly installed, 0 to remove and 0 not upgraded.
Need to get 130MB of archives.
After this operation, 247MB of additional disk space will be used.
Do you want to continue [Y/n]? 
Get:1 http://us.archive.ubuntu.com intrepid/universe libglib1.2ldbl 1.2.10-19build1 [123kB]
Get:2 http://us.archive.ubuntu.com intrepid/universe libgtk1.2-common 1.2.10-18.1build2 [209kB]
Get:3 http://us.archive.ubuntu.com intrepid/universe libgtk1.2 1.2.10-18.1build2 [877kB]
Get:4 http://us.archive.ubuntu.com intrepid/main libdbd-mysql-perl 4.007-1build1 [140kB]
Get:5 http://us.archive.ubuntu.com intrepid/main mysql-client-5.0 5.0.67-0ubuntu6 [7879kB]
Get:6 http://us.archive.ubuntu.com intrepid/main mysql-server-5.0 5.0.67-0ubuntu6 [26.8MB]
Get:7 http://us.archive.ubuntu.com intrepid/main pwgen 2.06-1 [19.5kB]         
Get:8 http://us.archive.ubuntu.com intrepid/main mysql-client 5.0.67-0ubuntu6 [52.7kB]
Get:9 http://us.archive.ubuntu.com intrepid/multiverse mythtv-common 0.21.0+fixes18722-0ubuntu1 [5703kB]
Get:10 http://us.archive.ubuntu.com intrepid/multiverse mythtv-database 0.21.0+fixes18722-0ubuntu1 [54.7kB]
Get:11 http://us.archive.ubuntu.com intrepid/universe libqt3-mt-mysql 3:3.3.8-b-5ubuntu1 [51.6kB]
Get:12 http://us.archive.ubuntu.com intrepid/multiverse libmyth-0.21-0 0.21.0+fixes18722-0ubuntu1 [8393kB]
Get:13 http://us.archive.ubuntu.com intrepid/multiverse mythtv-frontend 0.21.0+fixes18722-0ubuntu1 [2027kB]
Get:14 http://us.archive.ubuntu.com intrepid/multiverse libfame-0.9 0.9.1-0.2 [103kB]
Get:15 http://us.archive.ubuntu.com intrepid/universe liblzo1 1.08-3 [56.8kB]  
Get:16 http://us.archive.ubuntu.com intrepid/universe libpvm3 3.4.5-11 [91.7kB]
Get:17 http://us.archive.ubuntu.com intrepid/multiverse transcode 2:1.0.2-0.8ubuntu10 [2462kB]
Get:18 http://us.archive.ubuntu.com intrepid/multiverse mythtv-transcode-utils 0.21.0+fixes18722-0ubuntu1 [180kB]
Get:19 http://us.archive.ubuntu.com intrepid/universe libnet-upnp-perl 1.2.4-1~intrepid1 [50.3kB]
Get:20 http://us.archive.ubuntu.com intrepid/multiverse libmyth-perl 0.21.0+fixes18722-0ubuntu1 [50.1kB]
Get:21 http://us.archive.ubuntu.com intrepid/multiverse mythtv-backend 0.21.0+fixes18722-0ubuntu1 [1150kB]
Get:22 http://us.archive.ubuntu.com intrepid/main ntp 1:4.2.4p4+dfsg-6ubuntu2 [441kB]
Get:23 http://us.archive.ubuntu.com intrepid/multiverse mythtv 0.21.0+fixes18722-0ubuntu1 [30.5kB]
Get:24 http://us.archive.ubuntu.com intrepid/universe libsox0 14.0.1-2build2 [118kB]
Get:25 http://us.archive.ubuntu.com intrepid/universe libsox-fmt-alsa 14.0.1-2build2 [8030B]
Get:26 http://us.archive.ubuntu.com intrepid/universe libsox-fmt-base 14.0.1-2build2 [93.7kB]
Get:27 http://us.archive.ubuntu.com intrepid/multiverse mjpegtools 1:1.8.0-0.2ubuntu5 [541kB]
Get:28 http://us.archive.ubuntu.com intrepid/main mysql-server 5.0.67-0ubuntu6 [54.9kB]
Get:29 http://us.archive.ubuntu.com intrepid/multiverse mythtv-theme-blootube 1:0.21.0-0ubuntu1 [7358kB]
Get:30 http://us.archive.ubuntu.com intrepid/multiverse mythtv-theme-blootube-osd 1:0.21.0-0ubuntu2 [325kB]
Get:31 http://us.archive.ubuntu.com intrepid/multiverse mythtv-theme-blootube-wide 1:0.21.0-0ubuntu1 [18.1MB]
Get:32 http://us.archive.ubuntu.com intrepid/multiverse mythtv-theme-blootubelite-wide 1:0.21.0-0ubuntu1 [5783kB]
Get:33 http://us.archive.ubuntu.com intrepid/multiverse mythtv-theme-glass-wide 0.20080908-0ubuntu2 [7096kB]
Get:34 http://us.archive.ubuntu.com intrepid/multiverse mythtv-theme-gray-osd 0.21.0-0ubuntu2 [315kB]
Get:35 http://us.archive.ubuntu.com intrepid/multiverse mythtv-theme-isthmus 0.21.0-0ubuntu2 [349kB]
Get:36 http://us.archive.ubuntu.com intrepid/multiverse mythtv-theme-iulius 0.21.0-0ubuntu2 [414kB]
Get:37 http://us.archive.ubuntu.com intrepid/multiverse mythtv-theme-iulius-osd 0.21.0-0ubuntu2 [330kB]
Get:38 http://us.archive.ubuntu.com intrepid/multiverse mythtv-theme-minimalist-wide 0.21.0-0ubuntu2 [1895kB]
Get:39 http://us.archive.ubuntu.com intrepid/multiverse mythtv-theme-projectgrayhem 1:0.21.0-0ubuntu1 [3131kB]
Get:40 http://us.archive.ubuntu.com intrepid/multiverse mythtv-theme-projectgrayhem-wide 1:0.21.0-0ubuntu2 [3783kB]
Get:41 http://us.archive.ubuntu.com intrepid/universe mythtv-theme-mythbuntu 0.20080421 [7893kB]
Get:42 http://us.archive.ubuntu.com intrepid/multiverse mythtv-theme-mythcenter 0.21.0-0ubuntu2 [872kB]
Get:43 http://us.archive.ubuntu.com intrepid/multiverse mythtv-theme-mythcenter-wide 0.21.0-0ubuntu2 [1928kB]
Get:44 http://us.archive.ubuntu.com intrepid/multiverse mythtv-theme-neon-wide 1:0.21.0-0ubuntu4 [3691kB]
Get:45 http://us.archive.ubuntu.com intrepid/multiverse mythtv-theme-projectgrayhem-osd 1:0.21.0-0ubuntu2 [117kB]
Get:46 http://us.archive.ubuntu.com intrepid/multiverse mythtv-theme-retro 0.21.0-0ubuntu2 [2097kB]
Get:47 http://us.archive.ubuntu.com intrepid/multiverse mythtv-theme-retro-osd 0.21.0-0ubuntu2 [442kB]
Get:48 http://us.archive.ubuntu.com intrepid/multiverse mythtv-theme-titivillus 0.21.0-0ubuntu2 [5830kB]
Get:49 http://us.archive.ubuntu.com intrepid/multiverse mythtv-theme-titivillus-osd 0.21.0-0ubuntu2 [137kB]
Get:50 http://us.archive.ubuntu.com intrepid/multiverse mythtv-themes 0.21.0-0ubuntu2 [132kB]
Get:51 http://us.archive.ubuntu.com intrepid/universe sox 14.0.1-2build2 [61.6kB]
Get:52 http://us.archive.ubuntu.com intrepid/universe toolame 02l-6 [91.1kB]   
Get:53 http://us.archive.ubuntu.com intrepid/universe pvm 3.4.5-11 [164kB]     
Get:54 http://us.archive.ubuntu.com intrepid/multiverse transcode-doc 2:1.0.2-0.8ubuntu10 [292kB]
Fetched 130MB in 3min20s (650kB/s)                                             
Extracting templates from packages: 100%
Preconfiguring packages ...
Selecting previously deselected package libglib1.2ldbl.
(Reading database ... 157536 files and directories currently installed.)
Unpacking libglib1.2ldbl (from .../libglib1.2ldbl_1.2.10-19build1_i386.deb) ...
Selecting previously deselected package libgtk1.2-common.
Unpacking libgtk1.2-common (from .../libgtk1.2-common_1.2.10-18.1build2_all.deb) ...
Selecting previously deselected package libgtk1.2.
Unpacking libgtk1.2 (from .../libgtk1.2_1.2.10-18.1build2_i386.deb) ...
Selecting previously deselected package libdbd-mysql-perl.
Unpacking libdbd-mysql-perl (from .../libdbd-mysql-perl_4.007-1build1_i386.deb) ...
Selecting previously deselected package mysql-client-5.0.
Unpacking mysql-client-5.0 (from .../mysql-client-5.0_5.0.67-0ubuntu6_i386.deb) ...
Selecting previously deselected package mysql-server-5.0.
Unpacking mysql-server-5.0 (from .../mysql-server-5.0_5.0.67-0ubuntu6_i386.deb) ...
Selecting previously deselected package pwgen.
Unpacking pwgen (from .../archives/pwgen_2.06-1_i386.deb) ...
Selecting previously deselected package mysql-client.
Unpacking mysql-client (from .../mysql-client_5.0.67-0ubuntu6_all.deb) ...
Selecting previously deselected package mythtv-common.
Unpacking mythtv-common (from .../mythtv-common_0.21.0+fixes18722-0ubuntu1_all.deb) ...
Selecting previously deselected package mythtv-database.
Unpacking mythtv-database (from .../mythtv-database_0.21.0+fixes18722-0ubuntu1_all.deb) ...
Selecting previously deselected package libqt3-mt-mysql.
Unpacking libqt3-mt-mysql (from .../libqt3-mt-mysql_3%3a3.3.8-b-5ubuntu1_i386.deb) ...
Selecting previously deselected package libmyth-0.21-0.
Unpacking libmyth-0.21-0 (from .../libmyth-0.21-0_0.21.0+fixes18722-0ubuntu1_i386.deb) ...
Selecting previously deselected package mythtv-frontend.
Unpacking mythtv-frontend (from .../mythtv-frontend_0.21.0+fixes18722-0ubuntu1_i386.deb) ...
Selecting previously deselected package libfame-0.9.
Unpacking libfame-0.9 (from .../libfame-0.9_0.9.1-0.2_i386.deb) ...
Selecting previously deselected package liblzo1.
Unpacking liblzo1 (from .../liblzo1_1.08-3_i386.deb) ...
Selecting previously deselected package libpvm3.
Unpacking libpvm3 (from .../libpvm3_3.4.5-11_i386.deb) ...
Selecting previously deselected package transcode.
Unpacking transcode (from .../transcode_2%3a1.0.2-0.8ubuntu10_i386.deb) ...
Selecting previously deselected package mythtv-transcode-utils.
Unpacking mythtv-transcode-utils (from .../mythtv-transcode-utils_0.21.0+fixes18722-0ubuntu1_i386.deb) ...
Selecting previously deselected package libnet-upnp-perl.
Unpacking libnet-upnp-perl (from .../libnet-upnp-perl_1.2.4-1~intrepid1_all.deb) ...
Selecting previously deselected package libmyth-perl.
Unpacking libmyth-perl (from .../libmyth-perl_0.21.0+fixes18722-0ubuntu1_all.deb) ...
Selecting previously deselected package mythtv-backend.
Unpacking mythtv-backend (from .../mythtv-backend_0.21.0+fixes18722-0ubuntu1_i386.deb) ...
Selecting previously deselected package ntp.
Unpacking ntp (from .../ntp_1%3a4.2.4p4+dfsg-6ubuntu2_i386.deb) ...
Processing triggers for man-db ...
Setting up libdbd-mysql-perl (4.007-1build1) ...
Setting up mysql-client-5.0 (5.0.67-0ubuntu6) ...
Setting up mysql-server-5.0 (5.0.67-0ubuntu6) ...
 * Stopping MySQL database server mysqld                                 [ OK ] 
Reloading AppArmor profiles : done.
 * Starting MySQL database server mysqld                                 [ OK ] 
 * Checking for corrupt, not cleanly closed and upgrade needing tables.

Selecting previously deselected package mythtv.
(Reading database ... 161328 files and directories currently installed.)
Unpacking mythtv (from .../mythtv_0.21.0+fixes18722-0ubuntu1_all.deb) ...
Selecting previously deselected package libsox0.
Unpacking libsox0 (from .../libsox0_14.0.1-2build2_i386.deb) ...
Selecting previously deselected package libsox-fmt-alsa.
Unpacking libsox-fmt-alsa (from .../libsox-fmt-alsa_14.0.1-2build2_i386.deb) ...
Selecting previously deselected package libsox-fmt-base.
Unpacking libsox-fmt-base (from .../libsox-fmt-base_14.0.1-2build2_i386.deb) ...
Selecting previously deselected package mjpegtools.
Unpacking mjpegtools (from .../mjpegtools_1%3a1.8.0-0.2ubuntu5_i386.deb) ...
Selecting previously deselected package mysql-server.
Unpacking mysql-server (from .../mysql-server_5.0.67-0ubuntu6_all.deb) ...
 * Stopping MySQL database server mysqld                                 [fail] 
invoke-rc.d: initscript mysql, action "stop" failed.
invoke-rc.d returned 1
There is a MySQL server running, but we failed in our attempts to stop it.
Stop it yourself and try again!
dpkg: error processing /var/cache/apt/archives/mysql-server_5.0.67-0ubuntu6_all.deb (--unpack):
 subprocess pre-installation script returned error exit status 1
Selecting previously deselected package mythtv-theme-blootube.
Unpacking mythtv-theme-blootube (from .../mythtv-theme-blootube_1%3a0.21.0-0ubuntu1_all.deb) ...
Selecting previously deselected package mythtv-theme-blootube-osd.
Unpacking mythtv-theme-blootube-osd (from .../mythtv-theme-blootube-osd_1%3a0.21.0-0ubuntu2_all.deb) ...
Selecting previously deselected package mythtv-theme-blootube-wide.
Unpacking mythtv-theme-blootube-wide (from .../mythtv-theme-blootube-wide_1%3a0.21.0-0ubuntu1_all.deb) ...
Selecting previously deselected package mythtv-theme-blootubelite-wide.
Unpacking mythtv-theme-blootubelite-wide (from .../mythtv-theme-blootubelite-wide_1%3a0.21.0-0ubuntu1_all.deb) ...
Selecting previously deselected package mythtv-theme-glass-wide.
Unpacking mythtv-theme-glass-wide (from .../mythtv-theme-glass-wide_0.20080908-0ubuntu2_all.deb) ...
Selecting previously deselected package mythtv-theme-gray-osd.
Unpacking mythtv-theme-gray-osd (from .../mythtv-theme-gray-osd_0.21.0-0ubuntu2_all.deb) ...
Selecting previously deselected package mythtv-theme-isthmus.
Unpacking mythtv-theme-isthmus (from .../mythtv-theme-isthmus_0.21.0-0ubuntu2_all.deb) ...
Selecting previously deselected package mythtv-theme-iulius.
Unpacking mythtv-theme-iulius (from .../mythtv-theme-iulius_0.21.0-0ubuntu2_all.deb) ...
Selecting previously deselected package mythtv-theme-iulius-osd.
Unpacking mythtv-theme-iulius-osd (from .../mythtv-theme-iulius-osd_0.21.0-0ubuntu2_all.deb) ...
Selecting previously deselected package mythtv-theme-minimalist-wide.
Unpacking mythtv-theme-minimalist-wide (from .../mythtv-theme-minimalist-wide_0.21.0-0ubuntu2_all.deb) ...
Selecting previously deselected package mythtv-theme-projectgrayhem.
Unpacking mythtv-theme-projectgrayhem (from .../mythtv-theme-projectgrayhem_1%3a0.21.0-0ubuntu1_all.deb) ...
Selecting previously deselected package mythtv-theme-projectgrayhem-wide.
Unpacking mythtv-theme-projectgrayhem-wide (from .../mythtv-theme-projectgrayhem-wide_1%3a0.21.0-0ubuntu2_all.deb) ...
Selecting previously deselected package mythtv-theme-mythbuntu.
Unpacking mythtv-theme-mythbuntu (from .../mythtv-theme-mythbuntu_0.20080421_all.deb) ...
Selecting previously deselected package mythtv-theme-mythcenter.
Unpacking mythtv-theme-mythcenter (from .../mythtv-theme-mythcenter_0.21.0-0ubuntu2_all.deb) ...
Selecting previously deselected package mythtv-theme-mythcenter-wide.
Unpacking mythtv-theme-mythcenter-wide (from .../mythtv-theme-mythcenter-wide_0.21.0-0ubuntu2_all.deb) ...
Selecting previously deselected package mythtv-theme-neon-wide.
Unpacking mythtv-theme-neon-wide (from .../mythtv-theme-neon-wide_1%3a0.21.0-0ubuntu4_all.deb) ...
Selecting previously deselected package mythtv-theme-projectgrayhem-osd.
Unpacking mythtv-theme-projectgrayhem-osd (from .../mythtv-theme-projectgrayhem-osd_1%3a0.21.0-0ubuntu2_all.deb) ...
Selecting previously deselected package mythtv-theme-retro.
Unpacking mythtv-theme-retro (from .../mythtv-theme-retro_0.21.0-0ubuntu2_all.deb) ...
Selecting previously deselected package mythtv-theme-retro-osd.
Unpacking mythtv-theme-retro-osd (from .../mythtv-theme-retro-osd_0.21.0-0ubuntu2_all.deb) ...
Selecting previously deselected package mythtv-theme-titivillus.
Unpacking mythtv-theme-titivillus (from .../mythtv-theme-titivillus_0.21.0-0ubuntu2_all.deb) ...
Selecting previously deselected package mythtv-theme-titivillus-osd.
Unpacking mythtv-theme-titivillus-osd (from .../mythtv-theme-titivillus-osd_0.21.0-0ubuntu2_all.deb) ...
Selecting previously deselected package mythtv-themes.
Unpacking mythtv-themes (from .../mythtv-themes_0.21.0-0ubuntu2_all.deb) ...
Selecting previously deselected package sox.
Unpacking sox (from .../sox_14.0.1-2build2_i386.deb) ...
Selecting previously deselected package toolame.
Unpacking toolame (from .../toolame_02l-6_i386.deb) ...
Selecting previously deselected package pvm.
Unpacking pvm (from .../archives/pvm_3.4.5-11_i386.deb) ...
Selecting previously deselected package transcode-doc.
Unpacking transcode-doc (from .../transcode-doc_2%3a1.0.2-0.8ubuntu10_all.deb) ...
Processing triggers for man-db ...
Processing triggers for doc-base ...
Processing 1 added doc-base file(s)...
Registering documents with scrollkeeper...
Errors were encountered while processing:
 /var/cache/apt/archives/mysql-server_5.0.67-0ubuntu6_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
sgilmore at fry:~$


****************************************** END TERMINAL DUMP ******************************

Best regards and happy holidays!

Scott

ProblemType: Package
Architecture: i386
Dependencies:
 
DistroRelease: Ubuntu 8.10
ErrorMessage: subprocess pre-installation script returned error exit status 1
NonfreeKernelModules: nvidia ath_hal
Package: mysql-server None [modified: /var/lib/dpkg/info/mysql-server.list]
PackageArchitecture: all
SourcePackage: mysql-dfsg-5.0
Title: package mysql-server None [modified: /var/lib/dpkg/info/mysql-server.list] failed to install/upgrade: subprocess pre-installation script returned error exit status 1
Uname: Linux 2.6.27-9-generic i686

** Affects: mysql-dfsg-5.0 (Ubuntu)
     Importance: Undecided
         Status: New


** Tags: apport-package

-- 
package mysql-server None [modified: /var/lib/dpkg/info/mysql-server.list] failed to install/upgrade: subprocess pre-installation script returned error exit status 1
https://bugs.launchpad.net/bugs/310019
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to mysql-dfsg-5.0 in ubuntu.



More information about the Ubuntu-server-bugs mailing list