[Bug 259477] [NEW] mailx should not be Recommends

Mario Limonciello superm1 at ubuntu.com
Tue Aug 19 17:48:15 BST 2008


Public bug reported:

Recently w/ Recommends by default, mailx is getting installed as well as
exim4.  These should be dropped down to Suggests or a more sane solution
w/ virtual packages should be created.

kirkland> jdstrand: mysql-server has 'recommends' on mailx
<kirkland> jdstrand: that superm1 is trying to track down
<superm1> jdstrand, which is pulling in exim4 on intrepid now for all installs of mysql-server
<jdstrand> kirkland: as in 'why the Recommends'?
<jdstrand> superm1: not surprising, because of installing 'Recommends' by default
<kirkland> jdstrand: well, why, for one
<superm1> jdstrand, yeah i was attempting to argue the point that a mail server should be a separate task and more of an opt in scenario then opt out
<jdstrand> kirkland: I see in the changelog:
<jdstrand> mysql-dfsg-5.0 (5.0.18-7) unstable; urgency=low
<jdstrand>   * Made mailx in debian-start.inc.sh optional and changed the dependency on it
<jdstrand>     on it to a mere recommendation. Closes: #316297
<kirkland> jdong: and perhaps something more like postfix|mail-transport-agent
<kirkland> jdstrand: based on that changelog, we could probably lower it to a "Suggests"
<jdstrand> sounds like mailx should be bumped down to Suggests on Ubuntu...
<jdstrand> yea, what kirkland said ;P
<jdstrand> yeah even...
<kirkland> jdstrand: okay, if i make that change, can you upload it for me?
<kirkland> jdstrand: or do you think more discussion is required?
<jdstrand> what's ne more line of diff in an already humongous diff in mysql :)
<jdstrand> kirkland: no, I'll upload
<kirkland> jdstrand: :-P
<jdstrand> kirkland: it is clearly a problem and loads of packages are getting dropped to Suggests for just this reason

** Affects: mysql-dfsg-5.0 (Ubuntu)
     Importance: Undecided
         Status: New

-- 
mailx should not be Recommends
https://bugs.launchpad.net/bugs/259477
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to mysql-dfsg-5.0 in ubuntu.



More information about the Ubuntu-server-bugs mailing list