[Bug 258192] [NEW] problem with paths and binding to ldap server

Grzegorz Marszalek graf0 at post.pl
Fri Aug 15 16:19:39 BST 2008

Public bug reported:

Binary package hint: dhcp3-server-ldap

Description: Ubuntu 8.04
Release: 8.04
Package: dhcp3-server-ldap 3.1.1-1ubuntu1 (backport from interpid)

Well, when you put in dhcpd.conf something like this:
ldap-server "localhost";
ldap-username "cn=dhcp,dc=localdomain";
ldap-password "password";
ldap-method dynamic;
ldap-base-dn "dc=localdomain";

you expect everything to work as in docs :)

But for now each time I've got very strange error msg:
Cannot login into ldap server localhost:389: Success

Another problem was: dhcp server complained about path to leases file.

Both problems was solved by Holger Lüdecke, I've found his post here:
dist at lists.debian.org/msg529069.html

Thanks Holger! :)

I've attached patch which worked for me below.


** Affects: dhcp3 (Ubuntu)
     Importance: Undecided
         Status: New

** Tags: dhcp

problem with paths and binding to ldap server
You received this bug notification because you are a member of Ubuntu
Server Team, which is subscribed to dhcp3 in ubuntu.

More information about the Ubuntu-server-bugs mailing list