[USN-6399-1] Puma vulnerability

Marc Deslauriers marc.deslauriers at canonical.com
Wed Sep 27 13:10:00 UTC 2023


==========================================================================
Ubuntu Security Notice USN-6399-1
September 27, 2023

puma vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 23.04

Summary:

Puma could allow HTTP Request Smuggling attacks.

Software Description:
- puma: threaded HTTP 1.1 server for Ruby/Rack applications

Details:

It was discovered that Puma incorrectly handled parsing certain headers. A
remote attacker could possibly use this issue to perform an HTTP request
Smuggling attack.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 23.04:
   puma                            5.6.5-3ubuntu1.1

In general, a standard system update will make all the necessary changes.

References:
   https://ubuntu.com/security/notices/USN-6399-1
   CVE-2023-40175

Package Information:
   https://launchpad.net/ubuntu/+source/puma/5.6.5-3ubuntu1.1

-------------- next part --------------
A non-text attachment was scrubbed...
Name: OpenPGP_signature
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <https://lists.ubuntu.com/archives/ubuntu-security-announce/attachments/20230927/c29254e5/attachment.sig>


More information about the ubuntu-security-announce mailing list