[USN-6505-1] nghttp2 vulnerability

Marc Deslauriers marc.deslauriers at canonical.com
Wed Nov 22 16:01:00 UTC 2023


==========================================================================
Ubuntu Security Notice USN-6505-1
November 22, 2023

nghttp2 vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 23.10
- Ubuntu 23.04
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS

Summary:

nghttp2 could be made to consume resources if it received specially crafted
network traffic.

Software Description:
- nghttp2: HTTP/2 C Library and tools

Details:

It was discovered that nghttp2 incorrectly handled request cancellation. A
remote attacker could possibly use this issue to cause nghttp2 to consume
resources, leading to a denial of service.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 23.10:
   libnghttp2-14                   1.55.1-1ubuntu0.1
   nghttp2                         1.55.1-1ubuntu0.1
   nghttp2-client                  1.55.1-1ubuntu0.1
   nghttp2-proxy                   1.55.1-1ubuntu0.1
   nghttp2-server                  1.55.1-1ubuntu0.1

Ubuntu 23.04:
   libnghttp2-14                   1.52.0-1ubuntu0.1
   nghttp2                         1.52.0-1ubuntu0.1
   nghttp2-client                  1.52.0-1ubuntu0.1
   nghttp2-proxy                   1.52.0-1ubuntu0.1
   nghttp2-server                  1.52.0-1ubuntu0.1

Ubuntu 22.04 LTS:
   libnghttp2-14                   1.43.0-1ubuntu0.1
   nghttp2                         1.43.0-1ubuntu0.1
   nghttp2-client                  1.43.0-1ubuntu0.1
   nghttp2-proxy                   1.43.0-1ubuntu0.1
   nghttp2-server                  1.43.0-1ubuntu0.1

Ubuntu 20.04 LTS:
   libnghttp2-14                   1.40.0-1ubuntu0.2
   nghttp2                         1.40.0-1ubuntu0.2
   nghttp2-client                  1.40.0-1ubuntu0.2
   nghttp2-proxy                   1.40.0-1ubuntu0.2
   nghttp2-server                  1.40.0-1ubuntu0.2

In general, a standard system update will make all the necessary changes.

References:
   https://ubuntu.com/security/notices/USN-6505-1
   CVE-2023-44487

Package Information:
   https://launchpad.net/ubuntu/+source/nghttp2/1.55.1-1ubuntu0.1
   https://launchpad.net/ubuntu/+source/nghttp2/1.52.0-1ubuntu0.1
   https://launchpad.net/ubuntu/+source/nghttp2/1.43.0-1ubuntu0.1
   https://launchpad.net/ubuntu/+source/nghttp2/1.40.0-1ubuntu0.2

-------------- next part --------------
A non-text attachment was scrubbed...
Name: OpenPGP_signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <https://lists.ubuntu.com/archives/ubuntu-security-announce/attachments/20231122/b44a18f1/attachment.sig>


More information about the ubuntu-security-announce mailing list