[USN-6490-1] WebKitGTK vulnerabilities

Marc Deslauriers marc.deslauriers at canonical.com
Mon Nov 20 17:27:37 UTC 2023


==========================================================================
Ubuntu Security Notice USN-6490-1
November 20, 2023

webkit2gtk vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 23.10
- Ubuntu 23.04
- Ubuntu 22.04 LTS

Summary:

Several security issues were fixed in WebKitGTK.

Software Description:
- webkit2gtk: Web content engine library for GTK+

Details:

Several security issues were discovered in the WebKitGTK Web and JavaScript
engines. If a user were tricked into viewing a malicious website, a remote
attacker could exploit a variety of issues related to web browser security,
including cross-site scripting attacks, denial of service attacks, and
arbitrary code execution.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 23.10:
   libjavascriptcoregtk-4.0-18     2.42.2-0ubuntu0.23.10.1
   libjavascriptcoregtk-4.1-0      2.42.2-0ubuntu0.23.10.1
   libjavascriptcoregtk-6.0-1      2.42.2-0ubuntu0.23.10.1
   libwebkit2gtk-4.0-37            2.42.2-0ubuntu0.23.10.1
   libwebkit2gtk-4.1-0             2.42.2-0ubuntu0.23.10.1
   libwebkitgtk-6.0-4              2.42.2-0ubuntu0.23.10.1

Ubuntu 23.04:
   libjavascriptcoregtk-4.0-18     2.42.2-0ubuntu0.23.04.1
   libjavascriptcoregtk-4.1-0      2.42.2-0ubuntu0.23.04.1
   libjavascriptcoregtk-6.0-1      2.42.2-0ubuntu0.23.04.1
   libwebkit2gtk-4.0-37            2.42.2-0ubuntu0.23.04.1
   libwebkit2gtk-4.1-0             2.42.2-0ubuntu0.23.04.1
   libwebkitgtk-6.0-4              2.42.2-0ubuntu0.23.04.1

Ubuntu 22.04 LTS:
   libjavascriptcoregtk-4.0-18     2.42.2-0ubuntu0.22.04.1
   libjavascriptcoregtk-4.1-0      2.42.2-0ubuntu0.22.04.1
   libjavascriptcoregtk-6.0-1      2.42.2-0ubuntu0.22.04.1
   libwebkit2gtk-4.0-37            2.42.2-0ubuntu0.22.04.1
   libwebkit2gtk-4.1-0             2.42.2-0ubuntu0.22.04.1
   libwebkitgtk-6.0-4              2.42.2-0ubuntu0.22.04.1
   libwebkitgtk-6.0-dev            2.42.2-0ubuntu0.22.04.1

This update uses a new upstream release, which includes additional bug
fixes. After a standard system update you need to restart any applications
that use WebKitGTK, such as Epiphany, to make all the necessary changes.

References:
   https://ubuntu.com/security/notices/USN-6490-1
   CVE-2023-41983, CVE-2023-42852

Package Information:
   https://launchpad.net/ubuntu/+source/webkit2gtk/2.42.2-0ubuntu0.23.10.1
   https://launchpad.net/ubuntu/+source/webkit2gtk/2.42.2-0ubuntu0.23.04.1
   https://launchpad.net/ubuntu/+source/webkit2gtk/2.42.2-0ubuntu0.22.04.1

-------------- next part --------------
A non-text attachment was scrubbed...
Name: OpenPGP_signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <https://lists.ubuntu.com/archives/ubuntu-security-announce/attachments/20231120/ba88dbf7/attachment-0001.sig>


More information about the ubuntu-security-announce mailing list