[USN-4554-1] libPGF vulnerability

Eduardo Barretto eduardo.barretto at canonical.com
Mon Sep 28 19:20:36 UTC 2020


==========================================================================
Ubuntu Security Notice USN-4554-1
September 28, 2020

libpgf vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 16.04 LTS

Summary:

libPGF could be made to crash if it opened a specially crafted
file.

Software Description:
- libpgf: Progressive Graphics File (PGF) library

Details:

It was discovered that libPGF lacked proper validation when opening a
specially crafted PGF file. An attacker could possibly use this issue to
cause a denial of service.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 16.04 LTS:
  libpgf6                         6.14.12-3.1ubuntu0.1

In general, a standard system update will make all the necessary changes.

References:
  https://usn.ubuntu.com/4554-1
  CVE-2015-6673

Package Information:
  https://launchpad.net/ubuntu/+source/libpgf/6.14.12-3.1ubuntu0.1
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <https://lists.ubuntu.com/archives/ubuntu-security-announce/attachments/20200928/74fa0615/attachment-0001.sig>


More information about the ubuntu-security-announce mailing list