[USN-4514-1] libproxy vulnerability

Leonidas S. Barbosa leo.barbosa at canonical.com
Thu Sep 17 17:17:21 UTC 2020


==========================================================================
Ubuntu Security Notice USN-4514-1
September 17, 2020

libproxy vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS
- Ubuntu 16.04 LTS

Summary:

libproxy could be made to crash if it received a specially crafted PAC file.

Software Description:
- libproxy: automatic proxy configuration management library

Details:

It was discovered that libproxy incorrectly handled certain PAC files.
An attacker could possibly use this issue to cause a denial of service.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 20.04 LTS:
  libproxy1v5                     0.4.15-10ubuntu1.1

Ubuntu 18.04 LTS:
  libproxy1v5                     0.4.15-1ubuntu0.1

Ubuntu 16.04 LTS:
  libproxy1v5                     0.4.11-5ubuntu1.1

After a standard system update you need to restart your session to make
all the necessary changes.

References:
  https://usn.ubuntu.com/4514-1
  CVE-2020-25219

Package Information:
  https://launchpad.net/ubuntu/+source/libproxy/0.4.15-10ubuntu1.1
  https://launchpad.net/ubuntu/+source/libproxy/0.4.15-1ubuntu0.1
  https://launchpad.net/ubuntu/+source/libproxy/0.4.11-5ubuntu1.1
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <https://lists.ubuntu.com/archives/ubuntu-security-announce/attachments/20200917/4aefe4bf/attachment.sig>


More information about the ubuntu-security-announce mailing list