[USN-4282-1] PostgreSQL vulnerability

Marc Deslauriers marc.deslauriers at canonical.com
Tue Feb 18 14:03:00 UTC 2020


==========================================================================
Ubuntu Security Notice USN-4282-1
February 18, 2020

postgresql-10, postgresql-11 vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 19.10
- Ubuntu 18.04 LTS

Summary:

PostgreSQL could allow unintended access to the database.

Software Description:
- postgresql-11: Object-relational SQL database
- postgresql-10: Object-relational SQL database

Details:

It was discovered that PostgreSQL incorrectly performed authorization
checks when handling the "ALTER ... DEPENDS ON EXTENSION" sub-commands. A
remote attacker could possibly use this issue to drop any function,
procedure, materialized view, index, or trigger under certain conditions.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 19.10:
  postgresql-11                   11.7-0ubuntu0.19.10.1

Ubuntu 18.04 LTS:
  postgresql-10                   10.12-0ubuntu0.18.04.1

This update uses a new upstream release, which includes additional bug
fixes. After a standard system update you need to restart PostgreSQL to
make all the necessary changes.

References:
  https://usn.ubuntu.com/4282-1
  CVE-2020-1720

Package Information:
  https://launchpad.net/ubuntu/+source/postgresql-11/11.7-0ubuntu0.19.10.1
  https://launchpad.net/ubuntu/+source/postgresql-10/10.12-0ubuntu0.18.04.1

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <https://lists.ubuntu.com/archives/ubuntu-security-announce/attachments/20200218/c1a6d0f0/attachment.sig>


More information about the ubuntu-security-announce mailing list