[USN-4477-1] Squid vulnerabilities

Marc Deslauriers marc.deslauriers at canonical.com
Thu Aug 27 18:15:16 UTC 2020


==========================================================================
Ubuntu Security Notice USN-4477-1
August 27, 2020

squid vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 20.04 LTS

Summary:

Several security issues were fixed in Squid.

Software Description:
- squid: Web proxy cache server

Details:

Amit Klein discovered that Squid incorrectly validated certain data. A
remote attacker could possibly use this issue to perform an HTTP request
smuggling attack, resulting in cache poisoning. (CVE-2020-15810)

RĂ©gis Leroy discovered that Squid incorrectly validated certain data. A
remote attacker could possibly use this issue to perform an HTTP request
splitting attack, resulting in cache poisoning. (CVE-2020-15811)

Lubos Uhliarik discovered that Squid incorrectly handled certain Cache
Digest response messages sent by trusted peers. A remote attacker could
possibly use this issue to cause Squid to consume resources, resulting in a
denial of service. (CVE-2020-24606)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 20.04 LTS:
  squid                           4.10-1ubuntu1.2

In general, a standard system update will make all the necessary changes.

References:
  https://usn.ubuntu.com/4477-1
  CVE-2020-15810, CVE-2020-15811, CVE-2020-24606

Package Information:
  https://launchpad.net/ubuntu/+source/squid/4.10-1ubuntu1.2

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <https://lists.ubuntu.com/archives/ubuntu-security-announce/attachments/20200827/a4e78241/attachment-0001.sig>


More information about the ubuntu-security-announce mailing list