[USN-3178-1] icoutils vulnerabilities

Marc Deslauriers marc.deslauriers at canonical.com
Tue Jan 24 20:17:35 UTC 2017


==========================================================================
Ubuntu Security Notice USN-3178-1
January 24, 2017

icoutils vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 12.04 LTS

Summary:

icoutils could be made to crash or run programs as your login if it opened
a specially crafted file.

Software Description:
- icoutils: Create and extract MS Windows icons and cursors

Details:

It was discovered that icoutils incorrectly handled memory when processing
certain files. If a user or automated system were tricked into opening a
specially crafted file, an attacker could cause icoutils to crash,
resulting in a denial of service, or possibly execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 12.04 LTS:
  icoutils                        0.29.1-2ubuntu0.1

In general, a standard system update will make all the necessary changes.

References:
  http://www.ubuntu.com/usn/usn-3178-1
  CVE-2017-5208, CVE-2017-5331, CVE-2017-5332, CVE-2017-5333

Package Information:
  https://launchpad.net/ubuntu/+source/icoutils/0.29.1-2ubuntu0.1


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <https://lists.ubuntu.com/archives/ubuntu-security-announce/attachments/20170124/09e98975/attachment.pgp>


More information about the ubuntu-security-announce mailing list