[USN-2878-1] Perl vulnerability

Marc Deslauriers marc.deslauriers at canonical.com
Thu Jan 21 18:50:15 UTC 2016


==========================================================================
Ubuntu Security Notice USN-2878-1
January 21, 2016

perl vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 15.10
- Ubuntu 15.04

Summary:

Perl incorrectly handled the taint attribute.

Software Description:
- perl: Practical Extraction and Report Language

Details:

David Golden discovered that the canonpath function in the Perl File::Spec
module did not properly preserve the taint attribute. An attacker could
possibly use this issue to bypass the taint protection mechanism.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 15.10:
  perl                            5.20.2-6ubuntu0.1

Ubuntu 15.04:
  perl                            5.20.2-2ubuntu0.1

In general, a standard system update will make all the necessary changes.

References:
  http://www.ubuntu.com/usn/usn-2878-1
  CVE-2015-8607

Package Information:
  https://launchpad.net/ubuntu/+source/perl/5.20.2-6ubuntu0.1
  https://launchpad.net/ubuntu/+source/perl/5.20.2-2ubuntu0.1


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <https://lists.ubuntu.com/archives/ubuntu-security-announce/attachments/20160121/5bb737c5/attachment.pgp>


More information about the ubuntu-security-announce mailing list