[USN-2813-1] LXCFS vulnerabilities

Marc Deslauriers marc.deslauriers at canonical.com
Tue Nov 17 18:32:21 UTC 2015


==========================================================================
Ubuntu Security Notice USN-2813-1
November 17, 2015

lxcfs vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 15.10
- Ubuntu 15.04

Summary:

Several security issues were fixed in LXCFS.

Software Description:
- lxcfs: FUSE based filesystem for LXC

Details:

It was discovered that LXCFS incorrectly enforced directory escapes. A
local attacker could use this issue to possibly escalate privileges.
(CVE-2015-1342)

It was discovered that LXCFS incorrectly checked certain permissions. A
local attacker could use this issue t possibly escalate privileges.
(CVE-2015-1344)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 15.10:
  lxcfs                           0.10-0ubuntu2.1

Ubuntu 15.04:
  lxcfs                           0.7-0ubuntu4.1

After a standard system update you need to reboot your computer to make
all the necessary changes.

References:
  http://www.ubuntu.com/usn/usn-2813-1
  CVE-2015-1342, CVE-2015-1344

Package Information:
  https://launchpad.net/ubuntu/+source/lxcfs/0.10-0ubuntu2.1
  https://launchpad.net/ubuntu/+source/lxcfs/0.7-0ubuntu4.1


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <https://lists.ubuntu.com/archives/ubuntu-security-announce/attachments/20151117/dbe0f18c/attachment.pgp>


More information about the ubuntu-security-announce mailing list