[USN-2617-3] NTFS-3G vulnerability

Marc Deslauriers marc.deslauriers at canonical.com
Wed May 27 13:22:26 UTC 2015


==========================================================================
Ubuntu Security Notice USN-2617-3
May 27, 2015

ntfs-3g vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 15.04

Summary:

NTFS-3G could be made to overwrite files as the administrator.

Software Description:
- ntfs-3g: read/write NTFS driver for FUSE

Details:

USN-2617-1 fixed a vulnerability in NTFS-3G. The original patch did not
completely address the issue. This update fixes the problem.

Original advisory details:

 Tavis Ormandy discovered that FUSE incorrectly filtered environment
 variables. A local attacker could use this issue to gain administrative
 privileges.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 15.04:
  ntfs-3g                         1:2014.2.15AR.3-1ubuntu0.2

In general, a standard system update will make all the necessary changes.

References:
  http://www.ubuntu.com/usn/usn-2617-3
  http://www.ubuntu.com/usn/usn-2617-1
  CVE-2015-3202

Package Information:
  https://launchpad.net/ubuntu/+source/ntfs-3g/1:2014.2.15AR.3-1ubuntu0.2


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <https://lists.ubuntu.com/archives/ubuntu-security-announce/attachments/20150527/b2d0d1a5/attachment.pgp>


More information about the ubuntu-security-announce mailing list