[USN-1336-1] Linux kernel vulnerability

Marc Deslauriers marc.deslauriers at canonical.com
Mon Jan 23 15:22:22 UTC 2012


==========================================================================
Ubuntu Security Notice USN-1336-1
January 23, 2012

linux vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 11.10

Summary:

The system could be made to run programs as an administrator.

Software Description:
- linux: Linux kernel

Details:

Jüri Aedla discovered that the kernel incorrectly handled /proc/<pid>/mem
permissions. A local attacker could exploit this and gain root privileges.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 11.10:
  linux-image-3.0.0-15-generic    3.0.0-15.26
  linux-image-3.0.0-15-generic-pae  3.0.0-15.26
  linux-image-3.0.0-15-omap       3.0.0-15.26
  linux-image-3.0.0-15-powerpc    3.0.0-15.26
  linux-image-3.0.0-15-powerpc-smp  3.0.0-15.26
  linux-image-3.0.0-15-powerpc64-smp  3.0.0-15.26
  linux-image-3.0.0-15-server     3.0.0-15.26
  linux-image-3.0.0-15-virtual    3.0.0-15.26

After a standard system update you need to reboot your computer to make
all the necessary changes.

References:
  http://www.ubuntu.com/usn/usn-1336-1
  CVE-2012-0056

Package Information:
  https://launchpad.net/ubuntu/+source/linux/3.0.0-15.26


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 836 bytes
Desc: This is a digitally signed message part
URL: <https://lists.ubuntu.com/archives/ubuntu-security-announce/attachments/20120123/6c6b0c46/attachment.pgp>


More information about the ubuntu-security-announce mailing list