[Merge] lp:~phablet-team/indicator-network/fix-for-turbo into lp:indicator-network

Pete Woods pete.woods at canonical.com
Wed Apr 6 09:02:34 UTC 2016


Review: Needs Fixing

Looks good. Glad to get this dodgy regexp removed. Could you just fix the one simple comment. Thanks!

Diff comments:

> 
> === modified file 'src/indicator/nmofono/manager-impl.cpp'
> --- src/indicator/nmofono/manager-impl.cpp	2015-10-06 10:19:30 +0000
> +++ src/indicator/nmofono/manager-impl.cpp	2016-04-05 06:47:59 +0000
> @@ -445,7 +443,7 @@
>                                                  d->m_killSwitch);
>  
>              // We're not interested in showing access points
> -            if (!ACCESS_POINT_EXPRESSION.match(tmp->name()).hasMatch())
> +            if (tmp->name().compare(d->m_hotspotManager->interface()) != 0)

tmp->name() == d->m_hotspotManager->interface()
is probably a bit more readable

>              {
>                  tmp->setDisconnectWifi(d->m_hotspotManager->disconnectWifi());
>                  QObject::connect(d->m_hotspotManager.get(), &HotspotManager::disconnectWifiChanged,


-- 
https://code.launchpad.net/~phablet-team/indicator-network/fix-for-turbo/+merge/290735
Your team Ubuntu Phablet Team is subscribed to branch lp:~phablet-team/indicator-network/fix-for-turbo.



More information about the Ubuntu-reviews mailing list