[Merge] lp:~boiko/messaging-app/fill_contactwatcher into lp:messaging-app
Tiago Salem Herrmann
tiago.herrmann at canonical.com
Tue Oct 13 18:45:05 UTC 2015
Review: Needs Fixing
A few comments.
Also, it is not here in the diff, but can you rename the argument "participants" to "participantIds" in sendMessage() (and also update the function accordingly). The reason is that "participants" previously was a list of ids, but now it is a list of contact information. In the sendMessage() context we are only dealing with participantIds.
In MessageInfoDialog.qml there is also a message.participants[0] that should be message.participants[0].identifier, and PhoneUtils.format(modelData) that should be PhoneUtils.format(modelData.identifier)
Diff comments:
>
> === modified file 'src/qml/Messages.qml'
> --- src/qml/Messages.qml 2015-10-13 16:46:15 +0000
> +++ src/qml/Messages.qml 2015-10-13 16:46:15 +0000
> @@ -263,7 +277,9 @@
> multiRecipient.forceFocus()
> }
>
> - property string firstRecipientAlias: ""
> + property string firstRecipientAlias: (contactWatcher.isUnknown &&
Just a nitpick, but can you add additional parenthesis to make the expression more readable?
Any bug in this expression might cause the header to disappear.
((contactWatcher.isUnknown && contactWatcher.isInteractive) || contactWatcher.alias === "") ? contactWatcher.identifier : contactWatcher.alias
> + contactWatcher.isInteractive ||
> + contactWatcher.alias === "") ? contactWatcher.identifier : contactWatcher.alias
> title: {
> if (selectionMode) {
> return " "
--
https://code.launchpad.net/~boiko/messaging-app/fill_contactwatcher/+merge/273931
Your team Ubuntu Phablet Team is subscribed to branch lp:messaging-app.
More information about the Ubuntu-reviews
mailing list