[Merge] lp:~artmello/webbrowser-app/webbrowser-app-bookmarks_top_sites into lp:webbrowser-app

Olivier Tilloy olivier.tilloy at canonical.com
Fri Jul 4 07:13:55 UTC 2014


A tiny remark on semantics:

943	+    def ensure_new_tab_view_visible(self):
947	+    def ensure_new_tab_view_eventually_hidden(self):

Those two methods should be renamed:

    assert_new_tab_view_eventually_visible()
    assert_new_tab_view_eventually_hidden()

Methods that start with "ensure_" actually perform some actions to ensure that the result is achieved, as opposed to methods that start with "assert_" that merely wait until the condition is verified.
-- 
https://code.launchpad.net/~artmello/webbrowser-app/webbrowser-app-bookmarks_top_sites/+merge/224592
Your team Ubuntu Phablet Team is subscribed to branch lp:webbrowser-app.



More information about the Ubuntu-reviews mailing list