[Ubuntu-QC] Erreur de grub-install

Gilbert Dion gilbertdion at gmail.com
Mer 8 Oct 14:43:39 UTC 2014


Merci Steve pour ces informations. Comme l'ordinateur en cause n'est pas le
mien (c'est à un ami), je ne l'ai pas sous la main actuellement pour
vérifier si ces solutions fonctionnent. Je les retiens, cependant, et les
testerai dès que possible, ce qui ne se fera hélas pas avant la semaine
prochaine.

Gilbert

g

Le 8 octobre 2014 07:39, Steve Nadeau <stevenado at gmail.com> a écrit :

> Bonjour Gilbert,
>
> Tout d'abord, je n'utilise pas grub-efi-amd64-signed sinon grub-pc.
> Pour le UEFI, je ne l'utilise jamais je n'ai jamais de windows en
> parallèle, alors je le désactive toujours depuis le BIOS.
>
> lorsque je fait grub-install dans mon poste 64 bits, je reçois:
>
> grub-install /dev/sda
> Installing for i386-pc platform.
> Installation terminée, sans erreur.
>
> donc, il indique i386-pc
>
> j'imagine que le grub, bien que 64 bits, utilise ce répertoire pour
> simple compatibilité avec le passé bits pour être fonctionnel sur
> toutes les plate-formes, simple supposition. Probablement que le
> répertoire pourrait être nommé MODULES et personne n'en parlerait, car
> son contenu est un lot de .mod.
>
> si je fais un ls:
>
> ls /usr/lib/grub/ -l1
> total 36
> lrwxrwxrwx 1 root root    34 sep 29 18:15 grub-mkconfig_lib ->
> ../../share/grub/grub-mkconfig_lib
> drwxr-xr-x 2 root root 36864 sep 30 08:13 i386-pc
>
> donc, ça fait parti du grub ce répertoire.
>
> Étant donné qu'il y a un problème d'installation, il faudrait
> travailler pour solutionner ce problème, je ferais:
>
> apt-get purge grub-efi-amd64-signed
>
> rm -rf /usr/lib/grub
>
> apt-get install grub-efi-amd64-signed
>
> on s'assure que le répertoire sera recréé proprement, en espérant que
> cela puisse résoudre le tout.
>
>
> toutefois, je viens de trouver une page concernant un problème de grub
> efi, voir au bas de la page pour la résolution, peut-être essayer ça
> si ma solution n'a pas fonctionné.
>
> http://ubuntuforums.org/showthread.php?t=2223856&page=3
>
> bonne chance.
>
> Steve
> -----------------------------------
> www.equipeautonomiste.ca
> https://twitter.com/Autonomistes
> http://www.linkedin.com/company/3225935
> facebook.com/groups/equipeautonomiste
>
>
> Le 7 octobre 2014 19:47, Gilbert Dion <gilbertdion at gmail.com> a écrit :
> > J'ai soumis ce message il y a quelques semaines. Peut-être a-t-il tombé
> > entre deux craques. Je ne comprends pas pourquoi l'installation veut
> avoir
> > accès au répertoire 7usr/lib/grub/i386-pc. Le système est un 64 bits.
> >
> > Gilbert
> >
> > Bonjour,
> >
> > Chaque fois que j'installe des mises à jour, j'obtiens le message
> d'erreur
> > suivant:
> >
> > grub-install :  erreur : /usr/lib/grub/i386-pc/modinfo.sh n'existe pas.
> > Veuillez utiliser --target ou --directory.
> > dpkg: error processing package grub-efi-amd64-signed (--configure): le
> > sous-processus script post-installation installé a retourné une erreur de
> > sortie d'état 1 Des erreurs ont été rencontrées pendant l'exécution :
> > grub-efi-amd64-signed
> >
> > C'est nouveau depuis cet été, ce truc. C'est un ordinateur avec double
> > amorçage Windows 7 / Ubuntu, installé depuis plus de deux ans. Pour
> > démarrer Ubuntu il faut aller dans le bios et choisir Démarrage CSM au
> lieu
> > de Démarrage UEFI.
> >
> > C'est un Ubuntu 64 bits, je ne vois pas pourquoi il est mentionné dans le
> > message d'erreur «i386-pc».
> >
> > Quelqu'un a une idée?
> >
> > Merci d'avance,
> >
> > Gilbert
> >
> >
> > --
> > Ubuntu-quebec mailing list
> > Ubuntu-quebec at lists.ubuntu.com
> > https://lists.ubuntu.com/mailman/listinfo/ubuntu-quebec
> >
>
> --
> Ubuntu-quebec mailing list
> Ubuntu-quebec at lists.ubuntu.com
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-quebec
>
-------------- section suivante --------------
Une pièce jointe HTML a été nettoyée...
URL: <https://lists.ubuntu.com/archives/ubuntu-quebec/attachments/20141008/c7456f95/attachment.html>


More information about the Ubuntu-quebec mailing list