On Oct 14, 2009 7:50am, Joseph Salisbury <josephtsalisbury@gmail.com> wrote:<br />> On Wed, Oct 14, 2009 at 2:44 AM, Thierry Carrez<br />> <br />> thierry.carrez@ubuntu.com> wrote:<br />> <br />> > josephtsalisbury@gmail.com wrote:<br />> <br />> >> I noticed one other thing that may or may not be an issue. I installed<br />> <br />> >> the x86 version of Karmic on these machines. I set the ARCH variable to<br />> <br />> >> i386 when bundling the images. However, when I run euca-describe-images,<br />> <br />> >> I see the seventh column mention x86_64:<br />> <br />> >><br />> <br />> >> $ euca-describe-images<br />> <br />> >> IMAGE emi-22F111AC i-20091013143321/karmic-uec-i386.img.manifest.xml<br />> <br />> >> admin available public x86_64 machine<br />> <br />> >> IMAGE eki-403116B3<br />> <br />> >> k-20091013143321/karmic-uec-i386-vmlinuz-virtual.manifest.xml admin<br />> <br />> >> available public x86_64 kernel<br />> <br />> >> IMAGE eri-23C9163C<br />> <br />> >> r-20091013143321/karmic-uec-i386-initrd-virtual.manifest.xml admin<br />> <br />> >> available public x86_64 ramdisk<br />> <br />> >><br />> <br />> >> Is this to be expected?<br />> <br />> ><br />> <br />> > In doubt, please file a bug about it. I'm not exactly sure what's<br />> <br />> > expected here, but it sure looks wrong to me.<br />> <br />> ><br />> <br />> > --<br />> <br />> > Thierry Carrez<br />> <br />> > Ubuntu server team<br />> <br />> ><br />> <br />> <br />> <br />> I'll file a bug and investigate further.  Thanks for the information Thierry.<br />> <br /><br />Hi Thierry,<br /><br />Your updated test case corrected the issue with images being registered as x86_64 when they should be i386:<br /><br />$ euca-describe-images<br />IMAGE   eki-414A16BA    k-20091014123237/karmic-uec-i386-vmlinuz-virtual.manifest.xml   admin   available       public  i386    kernel<br />IMAGE   eri-24D11642    r-20091014123237/karmic-uec-i386-initrd-virtual.manifest.xml    admin   available       public  i386    ramdisk<br />IMAGE   emi-23FE11BA    i-20091014123237/karmic-uec-i386.img.manifest.xml      admin    available       public  i386    machine<br /><br />Thanks for updating the test case so quickly.  <br /><br />I'm having an issue starting an instance, which is the last command in step 7.  I still see the "disk not found" and "no domain with matching name found" errors, but I'm also seeing an error saying "no supported architecture for os type 'hvm'": <br /><br />[Wed Oct 14 14:57:00 2009][001691][EUCAINFO  ] currently running/booting:  i-39A80763<br />[Wed Oct 14 14:57:00 2009][001691][EUCAERROR ] libvirt: internal error no supported architecture for os type 'hvm' (code=1)<br />[Wed Oct 14 14:57:00 2009][001691][EUCAFATAL ] hypervisor failed to start domain<br />[Wed Oct 14 14:57:00 2009][001691][EUCAERROR ] libvirt: Domain not found: no domain with matching name 'i-39A80763' (code=42)<br />[Wed Oct 14 14:57:00 2009][001691][EUCAINFO  ] vrun(): [rm -rf /var/lib/eucalyptus/instances/admin/i-39A80763/]<br />[Wed Oct 14 14:57:01 2009][001691][EUCAINFO  ] stopping the network (vlan=10)<br /><br />I'll investigate and test further.<br /><br />Thanks,<br /><br />Joe