Problem z konfiguracją sieci domowej - pomocy

bartek wilczynski bartek w rezolwenta.eu.org
Śro, 5 Lip 2006, 10:14:38 BST



Cytowanie Grzegorz Musiał <g.musial w isklep.net>:

> Shot (Piotr Szotkowski) napisał(a):
> > darek:
> >
> >   
> >> Mam problem z skonfigurowaniem sieci domowej.
> >> Na głównym kompie mam Kubuntu, w nim sa dwie karty sieciowe.
> >> Dostawca przydzielił mi IP przez DHCP - czyli to jest tak do eth0 mam 
> >> podłączoną radiówkę z eth1 połaczony jest drugi komp krosówką, który 
> >> pracuje na XP-ku. Szukałem, kombinowałem jak to zrobić aby na obu 
> >> kompach był internet, ale niestety poległem - może to wina pogoda - 
> >> człowiekowi mózg się laszuje.
> >>     
> >
> > W moim przypadku (jeszcze na Debianie) wyglądało to tak:
> >
> > 0. Założenia: eth1 jest obsługiwana, sieć lokalną chcesz mieć w
> 192.168.1.*
> >
> > 1. Do /etc/network/interfaces dopisujesz
> >
> > auto eth1
> > iface eth1 inet static
> >    address 192.168.1.1
> >    netmask 255.255.255.0
> >
> > 2. `sudo ifup eth1`
> >   
> tutaj ja mam coś takiego
> sudo ifup eth1
> ifup: interface eth1 already configured

no to jeszcze wczesniej robisz 

`sudo ifdown eth1`

a potem 

`sudo ifup eth1`

Nastepnie instalujesz pakiet ipmasq jak juz napisano:
> 
> > 3. `sudo aptitude install ipmasq`
> >
> > 4. Nie ma punktu czwartego. :)
> >

powinno dzialac, ale jesli nie dziala, to jeszcze mozesz sprobowac zrestartowc
ipmasq czyli 

'sudo /etc/init.d/ipmasq restart`
> > Po tych krokach każdy wpięty do tak stworzonej sieci lokalnej komputer
> > może sobie sam wybrać adres (np. 192.168.1.7) i jeśli poprawnie mu
> > ustawisz DNS-a, to powinien działać. Praca domowa: postawienie na
> > routerze DHCP i DNS-a.
> >
No tutaj moze nalezaloby dodac, ze jesli nie uruchomisz u siebie serwera dhcp
(to temat na osbny post) to musisz sam recznie nadac takie wlasnie numery ip i
ustawic swoj adres (czyli 192.168.1.1) jako gateway (czyli bramke).

Gdybys mial jeszcze jakies problemy, to w nastepnym mailu podaj wyniki
nastepujacych polecen: 

/sbin/route
/sbin/ifconfig

> > -- Shot
> >   
> i lipa nie dziala :(
> 

-- 
pozdrowienia
   Bartek
--
For every complex problem there is an answer that is clear, simple, and wrong. 
                   H. L. Mencken




More information about the ubuntu-pl mailing list