[Bug 1706374] Re: ocata live migration won't work

Mehdi Abaakouk sileht at redhat.com
Thu Jul 27 07:14:06 UTC 2017


My guess is the regression was introduced by
https://libvirt.org/git/?p=libvirt.git;a=commitdiff;h=78a09aa033


Before when glisten->address was NULL, it was falling back to cfg.spiceListen and cfg.vncListen.
New code seems not doing this fallback.

If my guess becomes true, vnc have the same issue.

-- 
You received this bug notification because you are a member of Ubuntu
OpenStack, which is subscribed to Ubuntu Cloud Archive.
https://bugs.launchpad.net/bugs/1706374

Title:
  ocata live migration won't work

Status in Ubuntu Cloud Archive:
  New
Status in libvirt package in Ubuntu:
  New

Bug description:
  Hi,

  When I live migrate an instance that fail with the following error:

  
  2017-07-25 15:15:06.216+0000: starting up libvirt version: 2.5.0, package: 3ubuntu5.3~cloud0 (Openstack Ubuntu Testing Bot <openstack-testing-bot at ubuntu.com> Thu, 13 Jul 2017 13:56:34 +0000), qemu version: 2.8.0(Debian 1:2.8+dfsg-3ubuntu2.3~cloud0), hostname: xxxxx
  LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin QEMU_AUDIO_DRV=spice /usr/bin/kvm-spice -name guest=ac91b21c-f12d-4800-8416-c46e1f6a385e,debug-threads=on -S -object secret,id=masterKey0,format=raw,file=/var/lib/libvirt/qemu/domain-37-ac91b21c-f12d-4800-8/master-key.aes -machine pc-i440fx-zesty,accel=kvm,usb=off,dump-guest-core=off -cpu Nehalem -m 1024 -realtime mlock=off -smp 1,sockets=1,cores=1,threads=1 -uuid ac91b21c-f12d-4800-8416-c46e1f6a385e -smbios 'type=1,manufacturer=OpenStack Foundation,product=OpenStack Nova,version=15.0.5,serial=1c745dff-ee03-8cdd-6533-b53a563ccc20,uuid=ac91b21c-f12d-4800-8416-c46e1f6a385e,family=Virtual Machine' -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/domain-37-ac91b21c-f12d-4800-8/monitor.sock,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc,driftfix=slew -global kvm-pit.lost_tick_policy=discard -no-hpet -no-shutdown -boot strict=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-scsi-pci,id=scsi0,bus=pci.0,addr=0x4 -device virtio-scsi-pci,id=scsi1,bus=pci.0,addr=0x5 -device virtio-scsi-pci,id=scsi2,bus=pci.0,addr=0x6 -drive 'file=rbd:disks/ac91b21c-f12d-4800-8416-c46e1f6a385e_disk.config:id=openstack-service:key=xxxxxxxxxxxxxx:auth_supported=cephx\;none:mon_host=192.168.99.251\:6789\;192.168.99.252\:6789\;192.168.99.253\:6789,format=raw,if=none,id=drive-ide0-0-0,readonly=on,cache=none,aio=native' -device ide-cd,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive 'file=rbd:ssds/volume-699991c6-bcfd-4f33-b802-07e9ffcfd0fa:id=openstack-service:key=xxxxxxxxxxxxxxx:auth_supported=cephx\;none:mon_host=192.168.99.251\:6789\;192.168.99.252\:6789\;192.168.99.253\:6789,format=raw,if=none,id=drive-scsi0-0-0-0,serial=699991c6-bcfd-4f33-b802-07e9ffcfd0fa,cache=none,discard=unmap,aio=native' -device scsi-hd,bus=scsi0.0,channel=0,scsi-id=0,lun=0,drive=drive-scsi0-0-0-0,id=scsi0-0-0-0,bootindex=1 -netdev tap,fd=31,id=hostnet0,vhost=on,vhostfd=33 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=fa:16:3e:55:ea:93,bus=pci.0,addr=0x3 -add-fd set=2,fd=35 -chardev pty,id=charserial0,logfile=/dev/fdset/2,logappend=on -device isa-serial,chardev=charserial0,id=serial0 -device usb-tablet,id=input0,bus=usb.0,port=1 -spice port=5903,addr=None,disable-ticketing,seamless-migration=on -k en-us -device qxl-vga,id=video0,ram_size=67108864,vram_size=67108864,vram64_size_mb=0,vgamem_mb=16,max_outputs=1,bus=pci.0,addr=0x2 -incoming defer -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x7 -msg timestamp=on
  char device redirected to /dev/pts/4 (label charserial0)
  ((null):14760): Spice-Warning **: reds.c:2459:reds_init_socket: getaddrinfo(None,5903): Name or service not known
  2017-07-25T15:15:06.361848Z qemu-system-x86_64: failed to initialize spice server
  2017-07-25 15:15:06.428+0000: shutting down, reason=failed

  In nova.conf, spice have the following configuration:

  server_listen=0.0.0.0
  server_proxyclient_address=192.168.3.101

  
  The setup was working fine on newton, but since the upgrade to ocata, I got this error.

To manage notifications about this bug go to:
https://bugs.launchpad.net/cloud-archive/+bug/1706374/+subscriptions



More information about the Ubuntu-openstack-bugs mailing list