[ubuntu-nz] Broken update script

Liz Q liz at debian.co.nz
Mon Jun 4 23:34:40 BST 2007


On Tuesday 05 June 2007 10:19:48 Bob Harvey wrote:
> Hi,
>
> I seem to have broken the update mechanism on 6.10 Edgy.  I am in the
> middle of updating from 6.04 Dapper to 7.04 Feisty, which requires
> migrating via Edgy.  I have the official CDs for all three versions.  Got
> to 6.10 OK and popped in the 7.04 CD and then had two problems:
>
> First, although the 7.04 CD is identified when I load it and a file listing
> appears, no update autorun seems to happen.  I tried various things
> including terminal command: gksu "sh cdrom/cdromupgrade" to no avail (it
> starts, prompts for password, then ends back to the command prompt).
>
> Second, when I run a command like 'sudo apt-get check' I get the message:
> E: Malformed line 2 in source list
> /etc/apt/sources.list.d/dapper-universe.list (dist parse) E: The list of
> sources could not be read.
> The same message shows on the panel update indicator.
>
> The file /etc/apt/sources.list.d/dapper-universe.list looks like this:
> # automatically added by gnome-app-install on 2006-10-19 16:29:37.501471
> deb http://security.ubuntu.com/ubuntu edgy-security
> deb http://nz.archive.ubuntu.com/ubuntu/ edgy-updates universe
>
> Has anyone any idea what I have broken, and how to fix it?
the first line there looks like its missing something on the end. 
Generally from experiance it should look like this
deb http://security.ubuntu.com/ubuntu edgy-security main universe etc ...
It seems to be missing the rest of the line - try adding 'main' onto the end 
of it.

Liz



More information about the ubuntu-nz mailing list