Installeren van USB wireless adapter ICIDU wireless 150N

Jaap Woldringh jjh.woldringh op planet.nl
Za Jul 17 18:58:40 BST 2010


Hallo Floris,

Bedankt voor je antwoord.
Ik heb het nu ook geprobeerd met ndiswrapper, maar dat werkte ook niet
(.inf bestand vanaf de Windows-installatieschijf gehaald, en
ge´nstalleerd). Dit verklaart de tekst in dmesg:

17059.380033] usb 1-8: new high speed USB device using ehci_hcd and
address 6
[17059.530032] usb 1-8: configuration #1 chosen from 1 choice
[17059.589657] Disabling lock debugging due to kernel taint
[17059.611270] ndiswrapper version 1.55 loaded (smp=yes, preempt=no)
[17059.663216] usbcore: registered new interface driver ndiswrapper

Verder heb ik zoveel mogelijk ongedaan gemaakt wat ik tot nu toe heb
gedaan, en geef het even op. Ik vermoed dat of de firmware of de driver
nog niet af is (of beide), en erg experimenteel. Ik las over firmware
van diverse groottes, en dat die van 48 kb de juiste zou zijn, die ik
heb gevonden is 20 kb, en andere kan ik niet vinden. Ik heb begrepen dat
de chipset nog erg nieuw is, en afwijkend van andere ontwerpen.

Nogmaals: dank je wel voor je reactie.

Jaap

Op zaterdag 17-07-2010 om 18:34 uur [tijdzone +0200], schreef Floris:
> zo te zien moet je er bijna zijn. Wat ik nog zal proberen om
> meer informatie te vinden is het volgende:
> De computer opstarten zonder de usb adapter.
> Daarna de usb adapter aansluiten en kijken wat er onderaan
> in de log bestanden staat (dmesg of /var/log/messages). Misschien
> staat daar meer info.
> 
> succes,
> 
> floris
> 
> 
> Op Fri, 16 Jul 2010 14:59:11 +0200 schreef Jaap Woldringh  
> <jjh.woldringh op planet.nl>:
> 
> > Geachte lijst,
> >
> > Installatie van de USB WiFi adapter wireless 150N van ICIDU op Lucid
> > Out of the box werkt het niet.
> >
> > Onder WindowsXP werkt het goed, na installatie, dus het ding is niet
> > defect.
> >
> > Installatieaanwijzingen gevolgd die gegeven worden op
> > http://leonardom.wordpress.com/2010/05/24/install-wireless-usb-adapter-tl-wn721n-driver-on-ubuntu-10-4/
> > Dit zijn aanwijzingen voor de chipset Atheros ar9721, die in deze
> > adapter zit volgens:
> >
> > jaap op lawoe:~$ lsusb
> > Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> > ...
> > ...
> > Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> > Bus 001 Device 003: ID 0cf3:9271 Atheros Communications, Inc. <===
> > Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> >
> > De vereiste firmware (ar9271.fw) is nu aanwezig op de juiste plek, zie:
> > jaap op lawoe:~$ ls -al /lib/firmware/ar*
> > -rw-r--r-- 1 root root 83968 2010-05-26 18:10 /lib/firmware/ar9170-1.fw
> > -rw-r--r-- 1 root root 3508 2010-05-26 18:10 /lib/firmware/ar9170-2.fw
> > -rw-r--r-- 1 root root 15960 2010-05-26 18:10 /lib/firmware/ar9170.fw
> > -rw-r--r-- 1 root root 20480 2010-07-15 19:26 /lib/firmware/ar9271.fw
> >
> > Na de installatie is de driver ath9k_htc in de kernel aanwezig, volgens
> > jaap op lawoe:~$ lsmod | grep ath
> > ath9k_htc 37417 0
> > mac80211 231233 1 ath9k_htc
> > ath9k_common 4256 1 ath9k_htc
> > ath9k_hw 310956 2 ath9k_htc,ath9k_common
> > led_class 2864 1 ath9k_htc
> > ath 7977 2 ath9k_htc,ath9k_hw
> > cfg80211 145740 3 ath9k_htc,mac80211,ath
> > compat_firmware_class 6490 1 ath9k_htc
> >
> > Volgens gegevens die ik ergens op het internet heb gevonden ondersteunt
> > ath9k_htc hardware Atheros AR9001 en AR9002, en de chipsets AR9271 en
> > AR7010
> >
> > Maar zoals gezegd: ook na een herstart vertoont het ding geen enkel
> > teken van leven, en licht de led ook niet op, zoals ik dat onder Windows
> > heb gezien.
> >
> > Heeft iemand een idee wat ik nog moet doen?
> > Alvast bedankt
> > Jaap
> >
> >
> >





Meer informatie over de Ubuntu-NL maillijst