Onderwerp : Help burning udf image

Auteur : Guido Van Hoecke
E-mail : ubuntu op vanhoecke.org
Datum : Za Mrt 15 09:00:31 GMT 2008


I have an UDF image to be burnt, but none of the tools I tried seem to
recognise the filesystem. I installed and tried a sh.tload of tools,
a.o. gisomount, gmountiso, graveman, isomaster, cdw, dares etc... The
only tool which allowed me to have a look at the content is dares. It
did find all files, which gave me the assurance that there is nothing
wrong with the image.

I have googled around and really only found these two suggestions:
modprobe udf, and change the cdrom line in fstab:

% modprobe -l udf
/lib/modules/2.6.22-14-generic/kernel/fs/udf/udf.ko

% grep cdrom /etc/fstab
#/dev/hdb /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/hdb /media/cdrom0 auto user,noauto 0 0

When I open the file in mc, it only shows a readme file with following
text:

This disc contains a "UDF" file system and requires an operating system
that supports the ISO-13346 "UDF" file system specification.

When I burn the image, the drive spins for a short while, apparently
without writing anything, and almost instantly reports that there was an
error writing the cd.

Is there anything else to be done (besides the modprobe and the fstab
thing) to really enable udf support, or at least enable writing a dvd
from the image? I'd really hate to need a MS$ box for this.

TIA,

Guido